1

I cannot login via the GUI with a new user account I created in Ubuntu 16.0.4.5

I've read a lot of other threads that are similar to this problem, but nothing I've tried has worked.

The user has been added with a custom uid and gid - both 789. The new user doesn't have a .Xauthority file in its home dir. I attempted to remove the user and add it again with adduser but without luck.

The original user created during installation of Ubuntu 16.04.5 is able to login to the GUI without any problems.

I have tried uninstalling, reinstalling, and restarting the service lightdm without any luck.

I should also add that the new user has these permissions on its home dir, same as the other functioning user. drwxr-xr-x. Also I forgot to mention that on the login screen, the new users name is not displayed at all as an option, only the original user during installation and "guest" are available.

0

Unix-like systems including Linux derive some special meaning from user IDs of less than 1000. Here is a Unix Stack Exchange answer that explains some of the speciifcs, and a quick summary:

  • Less than 50 to 99 == high risks of conflicts with system applications
  • Less than 499 = risk of conflicts with programs
  • Less than 1000 = small risk of conflicts with programs
  • For network UID systems, you want to use only high numbers

Looking at the lightdm source code it does seem to treat UIDs below 1000 as "system" accounts and I found this question which provides information on a config file to specify the minimum user ID, which probably defaults to 1000:

How to make users with UID under 1000 appear in LightDM?

  • Thanks! Ill change the uid and gid for this new user. – openCivilisation Jan 25 at 6:43

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.