1

At the time of installation there was no sdk packages downloaded previously so when i tried downloading the sdk platforms, it shows error for Android Emulator as in screenshot. I am using proxy internet. Please suggest me the better solution. I tried taking ownership from root to myself but it didn't worked.

Error image

0

I ran the Android studio as administrator and then it worked. Go in the Android studio folder and type: sudo sh studio.sh

| improve this answer | |
  • How to do this? How to become administrator? – nilesh ingale Jan 24 '19 at 16:53
  • I tried running android-studio from root access but still the error is same. – nilesh ingale Jan 24 '19 at 17:09
  • Try sudo sh studio.sh in folder – erinnis Jan 24 '19 at 22:00
  • will you please explain the procedure? – nilesh ingale Jan 25 '19 at 5:43
  • Just go in android studio folder e type the command i write above – erinnis Jan 25 '19 at 6:44
0

There is an another way to install android studio on proxy internet without any errors. First download the packages from official site, www.developer.android.com and the extract that packages in a new folder named as Android. Then create a new folder and give it a name as Sdk. At the time of installation when setup will ask you for sdk folder, then give this path of Sdk folder that you have created. make sure that in Sdk folder you have a folder named as "platforms" so that it will download all the platforms in that folder. It will work smoothly.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.