5

Under settings, sharing there is no option for Screen Sharing however on another machine with exactly the same image there is an option for Screen Sharing. Any assistance would be appreciated.

  • 1
    Hi there, i didnt have that issue myself, but you could try reinstalling vino. vino/bionic,now 3.22.0-3ubuntu1 amd64 [installed] VNC server for GNOME Of course you should update: sudo apt-get update and then just reinstall: sudo apt-get install --reinstall vino Hope that helps! – Patient32Bit Jan 24 at 15:01
  • 1
    Hi Thanks for this however, still hasn't made any difference. I have computer name below in the Sharing menu in Settings however I do not have the "Screen Sharing" option below it. However on another Ubuntu machine I do. I have reinstalled it many times but still the same. Could it be hardware related? – Paddy Newton Jan 24 at 16:52
7

You are likely talking about minimal installation of Ubuntu 18.04, which doesn't provide vino. So just:

sudo apt-get install vino

the option is back!

  • This was my issue as well. I forgot I used minimal. I would also recommend the other answer of enabling dconf-editor after installing vino. The basic settings dont work due to bug in Ubuntu since 2014. Using dconf-editor one has to disable "encryption" so clients like Mac can connect – Abhishek Dujari May 18 at 14:05
  • Took me a while to find this! Totally saved me! – Tomas Gonzalez Dec 6 at 15:36
1

Install dconf Editor

sudo apt install dconf-editor

Open it and go to /org/gnome/desktop/remote-access/ you may find the settings there.

/org/gnome/desktop/remote-access/

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.