5

My dad bought a surface laptop for me. Can run Ubuntu on it? I tried and the keyboard does not work, so are there any version available?

4

Noo linux distro contains drivers for any of surface machines. Only way to make it work is with those guys https://github.com/jakeday/linux-surface

| improve this answer | |
1

Check out this tutorial on how to install Linux on a Microsoft Surface laptop.

In summary, the Secure Boot needs to be disabled and then the Surface laptop can be booted from a USB that has an Ubuntu image flashed on it.

The tutorial suggests first to "Try Out Ubuntu" instead of installing it at the start, to make sure that Ubuntu loads up successfully, which is a good idea. The tutorial also warns that:

WiFi does not work out of the box, so you will need to connect to the internet using a USB to ethernet converter to grab the Marvell WiFi driver.

There may be some commands to run in a terminal to get the hardware functional with the Ubuntu OS, such as the WiFi driver for the Surface laptop.

To troubleshoot the keyboard problem, try to plug an external keyboard into the USB port and test it. Maybe the kernel needs to be updated (see this question here and this tutorial here).

| improve this answer | |
  • 1
    The Surface Laptop is a standard laptop, this is the Surface Pro, which is a 2-in-1 and an entirely separate product. – xjcl Mar 12 '19 at 16:11
1

I bought an SP4 ages ago just to put Linux on it. At first, I used the Tigerite kernel, which worked well with no issues for me. After updating to 18.04 and getting the first official 5.0 kernel I have ever used on my SP4, almost everything works.

The only thing that does not work is the touchscreen, which includes the pen, which I couldn't care less about. No complaints on the current Ubuntu version. I have a working keyboard, touchpad, power saving (suspend, hibernate), Bluetooth, graphics drivers and more!

However, I tried to use the Jakeday kernel and had nothing but WiFi issues. The WiFi kept dropping and giving an auth error, but the touchscreen did work. So, I switched back to the official kernel and had no more problems. Use these custom kernels at your own risk.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.