0

I have an issue with my R7 360 graphic card within Ubuntu, maybe I have a problem because there is also an RX 550 installed.

My setup:

  • Ubuntu 18.04.1 fully updated (23.01.2019) installed in EFI mode

  • two GPUs both connected to my monitor

  • lspci -nn | grep -E 'VGA|Display'

    • 0b:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] [1002:665f] (rev 81)
    • Connected via HDMI
    • 43:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550/550X] [1002:699f] (rev c7)
    • Connected via DP
    • No additional drivers (both graphic cards should be work without properitary drivers: https://help.ubuntu.com/community/RadeonDriver )
  • MSI X399 SLI Plus
  • AMD Threadripper 2950X

I would like to use the R7 360 card for ubuntu and RX 550 for virtual machines (KVM GPU passthrough) So I followed this guide: https://heiko-sieger.info/running-windows-10-on-linux-using-kvm-with-vga-passthrough/ In short: use dummy drivers for the RX 550 card so that they are not used within ubuntu. After "update-initramfs -u" and rebooting I was not able to see anything but an orange screen. STRG + ALT + ENTF for reboot worked for me.

After recovering the initramfs by using a live system I just tried to change from mirroring to use the R7 360 as single monitor.

Now the strange thing, the mouse is working as expected but any input/window change (klick on button, move window, ...)/whatever is done witn an 3-5 seconds delay. Same thing for 3840*2160 and 1280*720. Also I could not see any sign that it is rendered in SW (top does not show a higher CPU usage for gnome-shell, Xorg or anything else). I am not able to reproduce this with mirrord displays. In this setup both GPUs are working as expected (and yes, I checked if the monitor uses HDMI) I also tried to reboot without any change.

The Device-Information shows anytime "Radeon RX 550 Series (POLARIS12 / DRM 3.23.0 / 4.15.0-43-generic, LLVM 6.0.0)" as GPU.

I tried to find something to change the primary GPU but the most guides are for Intel/Nvidia systems with Nvidia drivers to change this. I also could not find anything which could explain this delay.

In my opinion there are two possible action plans:

  • Try to resolve the delay issue, maybe by selecting the R7 360 as primary device. (but do not know how because I find only guides where this option is within a Nvidia Driver)
  • try to use dummy drivers for the RX 550 and hope that this will resolve the delay issue and not only the orange screen. (maybe using another guide but do not think that this will help)

Kind regards, Rene

  • They aren't the same but for purpose of passtrough your graphics cards should be considered the same - use the same driver - so this heiko-sieger.info/blacklisting-graphics-driver/… – GabrielaGarcia Jan 23 at 17:05
  • @GabrielaGarcia: I will check the link, thanks. Two different GPUs for passthrough are often used on home computers, and easier. So this should not be a problem for GPU passthrough. I already used GPU passthrough with intel as host-GPU and R7 360 as guest GPU. Additional info for R7 360: I used this card in my old PC with Ubuntu 18.04 without any (delay) issue. So I am wondering why it is a problem now. Maybe because the RX 550 is used as primary GPU? – Rene Jan 23 at 18:53
  • I just removed the RX 550 for a short time and the R7 360 worked as expected, "AMD Bonaire" is shown at settings -> Info instat og "Radeon RX 550 ...". After plug in the RX550 again there are the same issues again. I will try a little bit more but help would be great! :) – Rene Jan 23 at 19:44
0

Simple solution: I swapped the GPUs on the motherboard and the R7 360 is working. The Grafik "AMD Bonaire" is used, so R7 360 is now the primary card.

lspci -nn | grep -E 'VGA|Display' 0b:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Lexa PRO [Radeon RX 550/550X] [1002:699f] (rev c7) 43:00.0 VGA compatible controller [0300]: Advanced Micro Devices, Inc. [AMD/ATI] Tobago PRO [Radeon R7 360 / R9 360 OEM] [1002:665f] (rev 81)

Now I have to test the GPU-passthrough but I think this is offtopic for this.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.