I encountered the problem described in the title on Ubuntu 18.10 using the Unity desktop. I've tried restoring defaults on Unity Tweak Tool in case my theme was causing the problem, but it didn't fix anything. For some reason, clicking on one of the empty entries in Sublime text fixes the menu, but only temporarily, because after closing it and reopening it the problem reappears. I haven't found a solution for Deluge. I uploaded a video of my screen to make it easier to understand what's happening.

EDIT: This happens in Kubuntu too when using the Active Window Control widget to get a Unity-like global menu. Like in Unity, switching to another window and coming back to Sublime fixes the issue, however the right-click menu in Deluge stays broken. I believe in this case the issue could be caused by either the appmenu-gtk2-module or appmenu-gtk3-module package, because in order to enable global menu in gtk applications I had to install those packages and add appmenu-gtk-module to the GTK_MODULES environment variable. Anyway, I uploaded another video to show what I see exactly.

1 Answer 1


Solved by removing packages unity-gtk2-module and unity-gtk3-module. Now menus are shown inside the program's window instead of the global menu, and they show all entries both in Sublime and Deluge. Global menus are still present in all other applications I usually use, like Chromium, nautilus, etc. However, it would be nice to have the menu show up in the global menu instead of inside the windows.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.