0

As the title states, I am unable to install Ubuntu on my HP ENVY x360 - 15m-cn0011dx. The laptop has a M.2 NVME SSD, and the installer cannot locate it, gparted in a live environment cannot locate it, and I'm stumped.

I've tried all of the options in HPs bios.

I've disabled fastboot.

I confirmed there is no raid or optane running.

Other than wiping the SSD on another computer and trying it that way, I'm out of ideas.

Ideally, I'd dual boot with Windows, but any help is appreciated.

Edit: This is the laptop in question Best Buy Link

Edit 2 ) I have concluded that due to HP not allowing me to change the storage to AHCI, without replacing the SSD, a secondary OS (or installer) is unable to even detect the drive.

  • Was the nvme SSD factory installed or installed by you? – Tek Jan 22 at 16:07
  • @Tek The SSD is factory installed – Collin Jan 22 at 16:11
  • Did you make sure the nvme drive setting isn't RAID but AHCI in the bios? – Tek Jan 22 at 18:19
  • @Tek the lovely HP bios doesn't have an option to change raid settings. I can see the Intel RST setting and it says something to the effect of "not raid." I did see somewhere else about changing to AHCI in command prompt in Windows that I haven't tried yet – Collin Jan 22 at 18:22
  • @Tek askubuntu.com/a/776014/916633 is the post I referenced – Collin Jan 22 at 18:24

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.