I was stuck in a login loop on ubuntu 18.04 and tried a lot of the answers from other questions to no avail. Like here and here regarding .xauthority, cleaning disk space etc.

Eventually I installed xubuntu and can log in through that. However when I try to login in via ubuntu again (through the dropdown on the login) it goes back to a loop. I then need to restart to even be able to login with xubuntu.

Any ideas how to get back to ubuntu instead of xubuntu? Or where to look for starting points?

EDIT: Unity actually works fine as well so I have swicthed to this

  • 3
    I'd start by looking at your ~/.xsession-errors file after an unsuccessful login attempt – steeldriver Jan 22 at 14:13
  • Not finding anything in there after attempted ubuntu login – KGee Jan 24 at 13:05

Is it possible you've installed a display manager that isn't compatible with your graphics drivers? I've read that 18.04/18.10 has been causing a lot of trouble in regards to booting up/entering desktop, although more specifically for Nvidia graphics cards. You could try entering recovery mode to change the default display manager there, or if you're using Nvidia trying different Nouveau settings in GRUB (nouveau.modeset=0 or nomodeset).

In reply to your comment: the steps to take for a graphics problem is in the latter half. I actually just ran into the same exact issue as you after installing and subsequently uninstalling sddm. Unfortunately I didn't document the solution/process well enough to know what fixed it, so this is a shotgun approach.

Try these to fix the login issue:

Preface: my desktop environment is Plasma/KDE. Trying Gnome or Gnome with Wayland would kick me out too. When I tried KDE, it showed an error saying it couldn't write to, I believe .Xauthority or .ICEauthority, in my home folder. Here's what I tried:

  • At the login screen, open TTY with ctrl + alt + F6. (Once done with it you can leave with ctrl + alt + F1). For viewing/editing text in console I prefer using sudo nano datfile.

    • sudo apt install ubuntu-desktop. I think it's possible that sddm overwrote/edited essential files to desktop management. You should try

      sudo apt install ubuntu-desktop -f -y --reinstall --fix-missing

      as ubuntu-desktop is an essential package for your distro and it wouldn't install a package already there. Afterwards, run `

    • ubuntu-desktop isn't an essential package for my distro, but it might've helped. You can also try installing kubuntu-desktop as an alternative.

    • Take control of files related to desktop management with chown. Specifically .Xauthority and .ICEauthority in your home folder. You can try sudo chown username:username file.

I suggest taking a look at the manuals related to your issue: man startx, man xterm, man chown. You can try taking ownership of files man startx mention. If possible, posting your xsession_errors log located in your home folder may help.

These are the steps to take if it's a graphics drivers issue:

try these in the order they're in to see if it's solved.

  • Type in sudo nano /etc/default/grub to begin editing GRUB.
  • Look for the line that says quiet splash. Add nouveau.modeset=0 to the end of that, within the quotes. Press ctrl + O to write it out, then enter to save it. Ctrl + X to exit, sudo upgrade-grub to really save it. Reboot.
  • Open TTY and run `sudo apt remove nvidia* --purge -f -y". Reboot.
  • Add the proprietary gfx PPA with:

sudo add-apt-repository ppa:graphics-drivers/ppa

sudo apt-get update

In terminal, run ubuntu-drivers devices and it should spit out the apt packages that you can try installing, such as nvidia-driver-390. Install nvidia-settings as well, then reboot.

  • I think you may be correct, I am using an integrated Intel graphics controller. Do you know how to check if there are any incompatibilities? Sorry I am fairly new to this... – KGee Jan 24 at 12:44
  • You could try reading your /var/log/syslog for anything odd. I edited the original answer with some solutions you can try. – avisitoritseems Feb 14 at 8:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.