0

I have configured OpenLDAP server on CentOS 7.4 and client on Ubuntu 16.04. All the configuration has been done in server and client.
The issue is as follows:

When I boot my Ubuntu client laptop, it shows only locally created users on login screen. It shows WiFi available , but didn't connects to WiFI. When I login with local user Test it connects to Wifi. Now when i check /var/log/auth.log it shows the messages as

Jan 22 12:12:31 ppbldapc1 avahi-daemon[732]: nss_ldap: could not connect to any LDAP server as cn=ldapadm,dc=paytm-ldap,dc=net - Can't contact LDAP server
Jan 22 12:12:31 ppbldapc1 avahi-daemon[732]: nss_ldap: failed to bind to LDAP server ldap://10.11.80.49/: Can't contact LDAP server
Jan 22 12:12:31 ppbldapc1 dbus-daemon: nss_ldap: could not connect to any LDAP server as cn=ldapadm,dc=paytm-ldap,dc=net - Can't contact LDAP server
Jan 22 12:12:31 ppbldapc1 avahi-daemon[732]: nss_ldap: reconnecting to LDAP server...
Jan 22 12:12:31 ppbldapc1 dbus-daemon: nss_ldap: failed to bind to LDAP server ldap://10.11.80.49/: Can't contact LDAP server
Jan 22 12:12:31 ppbldapc1 sh: nss_ldap: could not connect to any LDAP server as cn=ldapadm,dc=paytm-ldap,dc=net - Can't contact LDAP server
Jan 22 12:12:31 ppbldapc1 sh: nss_ldap: failed to bind to LDAP server ldap://10.11.80.49/: Can't contact LDAP server
Jan 22 12:12:29 ppbldapc1 nscd: nss_ldap: could not connect to any LDAP server as cn=ldapadm,dc=paytm-ldap,dc=net - Can't contact LDAP server
Jan 22 12:12:29 ppbldapc1 nscd: nss_ldap: failed to bind to LDAP server ldap://10.11.80.49/: Can't contact LDAP server
Jan 22 12:12:29 ppbldapc1 nscd: nss_ldap: reconnecting to LDAP server...
Jan 22 12:12:29 ppbldapc1 nscd: nss_ldap: could not connect to any LDAP server as cn=ldapadm,dc=paytm-ldap,dc=net - Can't contact LDAP server
Jan 22 12:12:29 ppbldapc1 nscd: nss_ldap: failed to bind to LDAP server ldap://10.11.80.49/: Can't contact LDAP server

the getent and ldapsearch commands are fetching the data from LDAP server. At LDAP server there is one entry for connection established.

[root@ppbldaps anuj]# netstat -an | grep 389
tcp        0      0 0.0.0.0:389             0.0.0.0:*               LISTEN
tcp        0      0 10.11.80.49:389         10.11.32.135:40982      ESTABLISHED
tcp6       0      0 :::389                  :::*                    LISTEN

10.11.80.49 is server , 10.11.32.135 is client.
Base DN is dc=paytm-ldap,dc=net

Please suggest why i am getting not able to connect message at client while login and why it is not showing ldap user at gui login screen.

  • check your resolv.conf and ensure nameserver is pointed to your AD server and search to domain – user983418 Aug 8 at 20:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.