I tried to use Sound Converter to convert several folders of files from .m4a to .mp3 format and lost all file metadata in the conversion. I used Ubuntu 10.04 LTS with Sound Converter 1.4.4-2.

Is this expected? Should I be using another program to perform this function on Ubuntu?

  • Note: .m4a doesn't use ID3 tags but another way to specify metadata. Can you tell us what Sound Converter exactly you used (package name or website URL)?
    – JanC
    Nov 3, 2010 at 6:20
  • 2
    The package is likely to be "soundconverter" :)
    – Li Lo
    Nov 3, 2010 at 19:23
  • @JanC, @Li Lo: Now updated the q with details.
    – Alex Angas
    Nov 4, 2010 at 21:17

4 Answers 4


I tested soundconverter 1.4.4-2 using maverick and a sample Apple lossless in the .m4a container from here: http://samples.mplayerhq.hu/A-codecs/lossless/, the metadata is preserved after conversion to .mp3, I verified this with the Banshee media player,Totem and Rhythmbox, I even made copies of the file and tried a batch conversion and all files converted to .mp3 has the original metadata, I converted a .flac lossless to .mp4 also and again the metadata in the .flac was carried over to the .mp4 file, even the cover art from the flac file was there, I then converted the .mp4 audio file to .mp3 and the metadata was still there, I also used Easytag-aac to embed a cover art in the .m4a file and after conversion I was able to see the cover art in the .mp3 file when playing with Banshee.

From my experience here I would say that the loss of metadata after conversion with soundconverter should not be the expected outcome. Even this dated thread http://ubuntuforums.org/showthread.php?t=138419&page=3 from the Ubuntu forum shows that soundconverter is supposed to retain the tags in the output format.

  • Does it keep the cover art?
    – Flimm
    Feb 10, 2013 at 16:28

I've not used SoX but at last check it did deserve the appellation "the Swiss Army knife of sound processing programs".

It can be found in package sox.

  • Looks very powerful thank you. Only thing is I'm not a command line/script guru and the FAQ states no GUIs about being maintained.
    – Alex Angas
    Nov 4, 2010 at 21:21
  • if you open synaptic, and search for sox, you can right click it, click properties, and then in the last tab, you can find packages that depend on it, and see if there are any gui applications that use it. I believe there are some sox-based apps in there (but I cannot confirm right now) (worth a try though).
    – RolandiXor
    Nov 4, 2010 at 21:54

This is an old problem but it still exists, at least on Ubuntu 18.04 with SoundConverter 3.0. Unfortunately SoundConverter doesn't include all the necessary dependencies to convert the id3 information from flac files.

sudo apt install gstreamer1.0-plugins-bad-dbg gir1.2-gst-plugins-bad-1.0 gstreamer1.0-plugins-bad-doc

solved the problem for me. The above is no doubt overkill but I couldn't be bothered to isolate exactly which package installed the "id3mux" gstreamer element. More details can be found in this bug report. FWIW, I think a similar problem exists with AAC conversion and the "faac" gstreamer element also requires manual installation.


See this answer

You can do this with the



You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .