0

I don't have the library, libcrypto.so.1.1 on my Ubuntu machine. I checked on both, Ubuntu 14.04 and Ubuntu 16.04.

My openSSL version details are:

$ openssl version
OpenSSL 1.0.1f 6 Jan 2014

I tried running apt-get update and then apt-get install --only-upgrade openssl however it says that openssl is already in the newest version.

It seems that this library does not come by default with the OpenSSL package if installed through Ubuntu repositories.

0

According to the search results on packages.ubuntu.com - the libcrypto.so.1.1 file is placed in libssl1.1 package in Ubuntu 18.04 LTS (and newer versions).

So you can not get it on 14.04 and/or 16.04 from APT.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.