I'm dualbooting Ubuntu and Win7 (though I must admit I can count the number of times I've used Win7 during the last 6 months on one hand).

My laptop is a Acer TravelMate 8471.

One thing I noticed after the last time I rebooted in to Ubuntu were that my touchpad were acting a bit weird. Usually I scroll with two fingers (same on Win7), but suddenly my mouse would just jump around and send a lot of weird keypresses at the same time, when I tried to scroll. I tried having a look at the settings in the synclient, but everything seemed to be the same. I turned the touchpad off and then on, tried messing around with a lot of settings, but nothing seemed to help the two-finger scroll problem.

Then I rebooted my computer, but the problem was still there. At last I turned the computer off, waited 5 seconds and turned it on again. And all of a sudden my touchpad worked just as good as before.

This is happening every time I reboot from Win7, in to Ubuntu, and the only thing that fixes it, is to turn off the laptop, and then turn it on again (no waiting required).

My guess is that the Synaptics driver on Win7 does something to the touchpad, that is not reset before a complete power off.

Have anyone gotten any suggestions?


A lot of devices (especially in notebooks) don't only have drivers, but also a firmware that is stored in a flash memory. This firmware is not permanent - like firmwares on other device - but is put there by the driver in use.

The problem: The firmware is not cleared on reboot of shutdown if the flash still has power (i.e. standby-power). The firmware used by windows-drivers is often incompatible with that of Linux drivers. So for a lot of notebook-users the only way to get their hardware (e.g. WiFi) working again, is to turn the notebook off, remove the battery and wait a while.

There is no way around this, that I know of.

| improve this answer | |
  • Thought it would be something like this. Good thing is that it's not really a problem, rather than a minor inconvenience. Luckily the flash is powered off when the computer is turned of, so I don't need to remove the battery and all. – LasseValentini Nov 6 '10 at 5:11

You may be interested in installing the gpointing-device-settings, which will provide more configuration options for your touchpad. BTW, in Ubuntu 10.04LTS+ this replaces gsynaptics

sudo apt-get install gpointing-device-settings

Once installed you find it under System -> Preferences -> Pointing Devices.

| improve this answer | |

Sounds like the windows driver is updating a ram firmware on the device which is very incompatible with the Ubuntu driver. You could try disabling or upgrading the driver in windows and see if that solves the issue.

| improve this answer | |
  • I am using the latest driver for the touchpad, and I would rather live with the inconvenience than lose two finger scroll on Win7 (though I must admit it is not working quite as good as on Ubuntu:) Thanks for the quick reply. – LasseValentini Nov 6 '10 at 5:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.