0

Dell Vostro 2025 64-bit
Dual booting:
Ubuntu 18.04.03 LTS Bionic Beaver
Windows 10 Home
1 HDMI port
HDA Intel PCH (?) sound card/chipset (from aplay – see below)

In Windows I just plug the HDMI cable into the laptop and TV ports and – thanks to the wonders of plug'n'play – it all just works. The TV displays the video. The laptop speakers mute and the much superior sound comes out of the TV.

In Ubuntu, thanks to the novice unfriendly configuration, when you plug the HDMI cable into the laptop port it doesn't even recognise it. No, you have to switch off the laptop, plug in the cable, and then boot the laptop. Then you see only the laptop wallpaper on the TV while the video merrily plays on the laptop. But the sound still comes out of the laptop!

Why is using HDMI on Ubuntu so hard?

Can anyone help me with these issues:

  1. How to get the video to display on the TV?
  2. How to get the laptop sound muted and the sound directed to the TV?
  3. How to post an enhancement request to the bug reporter? It asks me what package is affected. How would I know? Can someone tell me which package to nominate?

$ aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: PCH [HDA Intel PCH], device 0: CS4213 Analog [CS4213 Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: PCH [HDA Intel PCH], device 3: HDMI 0 [HDMI 0]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
  • 2
    You only described what happens in windows 10. Please edit your question and tell us what does or does not work in Ubuntu. Also, the "correct behaviour" is highly opinion based. If I connect a TV to my laptop, I want the sound to switch over. If I connect an HDMI monitor with integrated speakers to my desktop PC which is connected to my 7.1 uber sound system, the sound should not switch over. But how would the OS know that? – danzel Jan 19 at 10:36
  • This is not a "correct behaviour" issue. It is a usability issue. I chose Ubuntu because it was the most user-friendly version of Linux distros, having previously tried Fedora, SuSE, and Mandrake. On Windows, if you want to set up a complex setup such as you describe, the tools are available to do this. But this not a very common usage taken over all users. Better would be dialogue which pops up and allows you to make the appropriate choices. – Hedley Finger Jan 21 at 1:16
  • 1
    Please take a look at the display settings and check if the TV really isn't recognized. It may only be disabled. Hot-plugging HDMI usually works out of the box. What you see (the wallpaper on the TV) is the equivalent of what is called extended displays in windows. On many laptops, there is a dedicated key to quickly switch between different multi-monitor configurations. There really is no usability issue here and there is no magic in what windows does. You have pretty much the same configuration options in both OSs. If you don't like the default config, that's personal taste, not usability. – danzel Jan 21 at 2:02
  • You may found useful this extension. – Pablo Bianchi Jan 21 at 4:18
0

This is only a partial answer 8^)

  1. Switch on the TV and insert the HDMI plug.
  2. Insert the other end of the cable into the laptop before switching it on.
  3. Click in the top-right hand corner to drop the system menu, then choose Settings (crossed screwdriver and spanner icon).
  4. Choose Devices > Screen Display page.
  5. Click the Mirror button to duplicate the laptop screen on the TV. (This button only appears when the HDMI cable is plugged into an active – switched on – TV, monitor or similar video- audio destination.)
  6. Still in the Settings app, choose Sound. The Sound page displays a list of possible outputs. (Thanks, BananaPeal.)
  7. Choose the HDMI output that represents your TV.
  8. Close the Settings app.*

After you unplug the TV, you will have to change the settings back to the default.

I said this is a partial answer. No-one has yet told me what the relevant packages are to report an improvement-request "bug".

* I am a retired technical writer. Does it show?

  • 1
    This really seems to be a problem with your specific computer. The second step should not be needed, and the audio output device should switch to an available one when the selected one disappears. Now that I had a look at the audio settings of gnome again (I use Kubuntu most of the time), I do agree with you regarding usability. That interface is missing important configuration options. Regarding step 5: you don't have to mirror the displays. In the "Join Displays" mode, you can move the window to your preferred display. – danzel Jan 21 at 2:42

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.