0

I need help figuring out why the 1st "Kernel" section of boot time shown by "systemd-analyze plot" is 67 seconds long. How do I debug that part of the boot process?

I've been looking around and see a lot of posts discussing various things that either don't apply to my system or didn't make much difference.

-- apt-daily.service was running during boot so I followed instructions to create an override.conf file and removed it from the boot sequence. No real improvement, but it's not part of boot anymore.

-- I see reports about bugs in the 4.15.0-24 kernel but I run 4.15.0-43-generic.

-- I see discussions about swap partitions, but I don't have one. Posts I read say 18.04 uses swap files and they are just fine vs. having a swap partition.

-- When I run "systemd-analyze critical-chain" the first several entries (starting with "graphical.target") all end in @52.342s but I'm not sure what they mean.

-- The top several entries from "systemd-analyze blame" are

------- 31.636s for lightdm.service

------- 31.625s for plymouth-quit-wait.service

------- 14.750s for dev-sda1.device

------- 9.733s for systemd-journal-flush.service

------- and then it's keyboard, network, disks and stuff under 7 seconds each after that.

-- I like hibernation so I didn't play with the "noresume" setting in Grub.

This problem started when I decided to try 18.04 on a spare laptop. I reformatted the whole 750GB drive into one single EXT4 partition by rewriting the previous partition table. That worked fine and I installed 18.04 from a live CD.

I previously ran 16.04 and 18.04 on this same machine with no problems. The first version of 18.04 was an update from 16.04 but had functional problems. I decided to retry 18.04 as a clean install on a clean disk and that's when the speed problem started.

So, any ideas how to figure this out? I want to lend this laptop to a friend as a trial step into linux and having a long boot time like this will be a turn off for him.

0

Solved it.

My computer is a Dell Inspiron 1520 and there is a bug in the kernel that affects those laptops. It tries to start an svideo adapter, which the laptop doesn't have.

This post has the solution: Boot very slow because of drm_kms_helper errors

The solution is to disable the svideo connector using grub at boot up.

sudo nano /etc/default/grub

Add the kernel boot parameter: video=SVIDEO-1:d, so it will look like this: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash video=SVIDEO-1:d"

sudo update-grub sudo reboot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.