0

I have a transmission-daemon 2.94 (d8e60ee44f) set up on a Ubuntu 18.04.1 server, but it seems not to be working correctly. If i test the port using transmission-remote -n '_____:______' -pt I get the following error: Error: portTested: http error 0: No Response

Testing the port with curl http://portcheck.transmissionbt.com/[port-number] i get: 1

I saw in a different post something similar but their problem was on the /etc/resolv.conf permissions, mine are: -rw-r--r-- 1 root root 54 Dec 1 16:55 /etc/resolv.conf

And if i log in with the debian-transmission i have no problem resolving any url.

If i try to add a torrent via transmission-remote i get a diferent error: Error: gotMetadataFromURL: http error 0: No Response And if i add it via the web interface i can see on the logs Could not connect to tracker (announcer.c:996)

I tried to purge and reinstall, but the errors won't get fixed. Any thoughts on how to debug this issue or what could be the problem? Disabling IPv6 didn't work either (https://forum.transmissionbt.com/viewtopic.php?f=2&t=19152#p76510)

0

[SOLVED]: I think the issue was on the bind-address-ipv6 i did the following modifications and now its working:

10c10
<     "bind-address-ipv6": "::1",
---
>     "bind-address-ipv6": "::",
68c68
<     "umask": 2,
---
>     "umask": 10,
  • The above below answer is misleading. "bind-address-ipv6": "::1" effectively gets transmission to bind to local loopback interface ::1 is equivalent to 127.0.0.1 in ipv4. This effectively disables ipv6 for transmission. – user983511 Aug 9 at 5:16
  • @OlegR The diff output in this answer suggests that the OP changed the original value of ::1 to ::, which should be the default route (0.0.0.0 IPv4 equivalent), so this seems correct to me. – Byte Commander Aug 10 at 11:20

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.