0

I have spent hours trying and I am still unable to use a secondary display with my laptop. I tried to connect directly via HDMI port (tried different displays) as well as through DisplayPort on a TB16 Thunderbolt Dock. All works on dual-boot Windows.

Any clues based on my diagnostic data below?

$ inxi -Fxz

System: Host: XXX-XPS-15-9560 Kernel: 4.15.0-43-generic x86_64 bits: 64 gcc: 7.3.0 Desktop: Gnome 3.28.3 (Gtk 3.22.30-1ubuntu1) Distro: Ubuntu 18.04.1 LTS Machine: Device: laptop System: Dell product: XPS 15 9560 serial: N/A Mobo: Dell model: 05FFDN v: A00 serial: N/A UEFI: Dell v: 1.12.1 date: 10/02/2018 CPU: Quad core Intel Core i7-7700HQ (-MT-MCP-) arch: Skylake rev.9 cache: 6144 KB flags: (lm nx sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx) bmips: 22464 clock speeds: max: 3800 MHz 1: 893 MHz 2: 945 MHz 3: 918 MHz 4: 977 MHz 5: 983 MHz 6: 944 MHz 7: 947 MHz 8: 916 MHz Graphics: Card-1: Intel Device 591b bus-ID: 00:02.0 Card-2: NVIDIA GP107M [GeForce GTX 1050 Mobile] bus-ID: 01:00.0 Display Server: x11 (X.Org 1.19.6 ) drivers: nvidia,fbdev,nouveau (unloaded: modesetting,vesa) Resolution: 3840x2160@88.00hz OpenGL: renderer: llvmpipe (LLVM 6.0, 256 bits) version: 3.3 Mesa 18.0.5 Direct Render: Yes

$ xrandr

xrandr: Failed to get size of gamma for output default Screen 0: minimum 3840 x 2160, current 3840 x 2160, maximum 3840 x 2160 default connected primary 3840x2160+0+0 0mm x 0mm 3840x2160
88.00*

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.