1

I have exactly the same problem with this answer. I don't understand why that topic is closed.

I cannot login my desktop for first time after using and trusting the new Ubuntu so many months already.

I have compared my updates history with the link I posted above and I m quite sure that the culprit is on one of these two updates:

  1. libgjs0g:amd64
  2. gjs:amd64

PS. I don't want to upgrade to 18.10...wanna stay LTS

  • once i had a log in loop because i went out of space, if i remember well. by doing sudo apt-get -y autoremove && sudo apt-get -y clean the problem was solved. perhaps you can log in if u switch to another session with CTRL+F2 or try the recovery mode and run the command on that level -> see: askubuntu.com/questions/24006/… – AlexOnLinux Jan 18 at 14:13
  • For sure I am not out of space. I think it's not a coincidence that two of my updates are the same with the other guy's updates in the link I posted before.thanks anyway – Georgens Jan 18 at 14:49
  • I have tried all the old tricks related to the same login loop issue, stop&restart gdm,chown the .iceauthority etc. None of them works! – Georgens Jan 18 at 15:04
  • In your question, you write that you think you know the culprit. If so, then what sort of help are you asking for? The question you want answered does not seem clear. – user535733 Jan 18 at 15:23
  • I just provide some information that maybe can shed some light what causes that loop. That I found, probably, the cause doesn't mean I can solve it. I can't remove these two packages,and I can't go back downgrading to previous version. Just an basic update routine turned to be a nightmare,so if anyone can help would be nice – Georgens Jan 18 at 15:35
1

SO I WAS RIGHT. Finally I managed to downgrade the gjs and libgjs0 to the previous version and solved my problem.

Now I have to prevent this particular update to happen... HOPE PEOPLE WILL BE MORE CAREFUL WITH UPDATES...

Update: I followed this link to roll back and prevent: Is there any way to roll back the most recent upgrade?

Locking version from synaptic is also an option to block the updates. Cheers

  • Congratulations! You solved my problem too! I had reinstalled 18.04.1 without any updates, but now I've blocked gjs' and libgjs0g' version to 1.52.1 (in Synaptic) to prevent the update to 1.52.5, then I've updated my system and all works fine. Thanks! – Sergio Jan 20 at 21:55
  • Great that worked! It would kill me to reinstall the OS again along with all my stuff,so I followed this after Ctrl+alt+f3 ...askubuntu.com/questions/34888/… – Georgens Jan 21 at 23:21
0

I was having the same problem, but went for a different solution:

I noticed that if I created a new user the login of that user went fine. I assumed then the problem was in my user config. So I made a backup of my home folder and removed my original user.

Then I created it again and login was successful. Of course I have lost all my configs, but the programs were still installed. Then I started to copy back folder by folder from my backup home to my new, clean, home.

I narrowed down the issue to the gnome extensions folder. As soon as I copied it back, the login loop happened again. I can't tell which extension was causing the issue, because I removed the extensions folder and reinstalled them using Chrome.

the folder location is: HOME/.local/share/gnome-shell/extensions

Hope this helps users that had this issue. It was quite painful to see a LTS block in that way.

Cheers

  • As to which extension was causing the issue, did you install workspace-grid? – Sergio Jan 22 at 20:51
0

In my case, the problem was the app indicator-multiload, that I had recently installed. So, the solution was simply

sudo apt remove indicator-multiload

I suspect it must have collapsed somehow with the GNOME extensions, in the line of procopiostein's answer .

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.