0

I'm trying to install ubuntu in dual boot along with windows 10. I have two hard disks. Windows is already installed in disk0. Then I installed ubuntu 18.04 LTS in disk0 after windows. Both were working fine. But every time I restart, it used to load windows by default. To enable grub, I found the below command and executed in windows command prompt with administrator privilages

bcdedit /set {bootmgr} path \EFI\ubuntu\grubx64.efi

After this, whenever I reboot, it opens Grub command line. If I go to bios/uefi, I can start ubuntu from there or I can select Windows Boot Manager. Ubuntu is working fine, but if I select Windows Boot Manager, again I get into Grub command line. So, I'm not able to boot windows at all.

How to fix this? I found a command to undo bcdedit

bcdedit /deletevalue {bootmgr} path \EFI\ubuntu\grubx64.efi

But to execute this, I need to be in windows right? So, I'm not able to execute this command. Is there a way to perform this action from bios/uefi (Asus computer) or from the ubuntu? (Ubuntu is booting fine)

Or is there any other method? I'm open to all suggestions.

Additional Info: Also, I installed grub2 and now I'm able to see grub bootloader after restart. Here, I get 2 options: ubuntu and windows (from sda2). If I select Ubuntu, ubuntu loads fine. But if I select windows, I get an error saying invalid signature

Edit 01: I ran boot-repair tool. The details are in this paste ubuntu

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.