0

I recently bought an gaming laptop (the Gigabyte Sabre 15) with an Nvidia geforce gtx 1050. I had trouble with the graphic card during the installation of ubuntu and I had to boot with acpi=off.

Now everything is installed (including Nvidia drivers which was not as easy as usual) and i don't want my computer to boot with acpi=off anymore because it causes trouble with my keyboard and touchpad. I can disable it at start up by going into the grub and then by erasing "acpi=off" in the boot parameter, but then it works just once. And i don't want to do it at every boot.

Someone could give me a permanent solution? Thank you!

1

To permanently remove acpi=offfrom the GRUB options, you have to edit the file /etc/default/grub.

You'll find a line like

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"

or similar (the important part is GRUB_CMDLINE_LINUX_DEFAULT, and obviously there should be acpi=off).

Just remove the acpi=off part (GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"), save, exit and run

sudo update-grub

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.