0

This “No object for D-Bus interface” message is very specific, and not addressed by similar questions relating to the same message.

The message occurs when I try to mount in Nautilus on Ubuntu (and also on PCManFM file manager on Parted Magic) after I have changed either a partition or the partition table.

Most crucially, this happens on only one hard drive. The drive is brand new. I unsealed the anti-static wrapping and the first thing I did was use GParted (on Parted Magic) to create an MSDOS partition table and one NTFS partition. I tried to mount with the file manager and received the message. I tried partitioning on Ubuntu and had the same result. The drive is fine, and has no errors. I've partitioned many hard drives, but this one particular HDD is the only one I've ever experienced this issue with.
The HDD info is:
WD Blue 2TB Desktop Hard Disk Drive - 5400 RPM SATA 6 Gb/s 64MB Cache 3.5 Inch - WD20EZRZ

This is a new hard disk drive, dated 26 June 2018. I was partitioning on an older Dell Optiplex 745, so I'm wondering if there's a firmware issue or perhaps the Dell's BIOS is not entirely compatible with the drive. It's a stretch, but what else could be so specific to one hard drive?

After I reset the computer, or detach the drive and try it on other computers everything is fine. It mounts/unmounts without a problem, so far. Works fine on Windows too. If this is the only oddity, needing to reset or reattach once to restore proper behavior, I can live with it. I just want to know if the hard drive is defective, in which case I'll need to return it, which I would rather avoid.

Some more symptoms:
On Ubuntu if I change a partition Nautilus will not update its display, still showing the previous partition label, and I get the D-Bus message. If I create a partition table then Nautilus updates its display and everything works. On Parted Magic it's the other way, partitioning seems okay, but creating a partition table results in the message, unless I obsessively re-create the table a few times, then the file manager updates and I can mount the new partition. In all cases I can see and mount the partition through other means, like lsblk. The problem occurs with the graphical file managers.

I know the issues likely involve UUID, /etc/fstab, and gvfs. This only occurs during the initial login session, so I would need to recreate the scenario to test all these things since the problem seems to resolve itself with a reset.

Bottom line: Should I return the drive?

I was testing with Ubuntu 14.04 and Parted Magic ver. 2017-09-05.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.