0

Update 2

I have followed the given instructions in the next three screens:

1st screen:

GNU GRUB  version 2.02-2ubuntu8.9

setparams 'Check disc for defects'
         set gfxpayload=keep
         linux     /casper/vmlinuz boot=casper integrity-check noapic noacpic quiet splash ---
         initrd    /casper/initrd.lz

The result was:

enter image description here

Then, I restarted the computer, enter to windows 10 an do the known steps and I got:

enter image description here

Then the screen freezes.

Supposition: I guess that the UEFI or more generally my laptop does not start the graphical environment to start the trying or installing Ubuntu options. (It's a supposition because I am not well-versed in either BIOS or UEFI.)

Update 1

I have tried to install Ubuntu from a DVD, and I got the following errors right after choosing to try or install Ubuntu:

enter image description here

enter image description here

[Old post]

I want to install Ubuntu with dual boot with Windows 10. When I finally made my laptop to read my bootable USB flash (Etcher) I got:

enter image description here

I have spent three days and I do not know what else to do.

I have done:

  1. disable fast boot
  2. disable Intel fast storage
  3. disable secure boot
  4. I have made a partition from windows
  5. enter to the USB from windows option of restarting
  6. I get the UEFI black screen to choose what to do and I get the same screen no matter if a choose to try Ubuntu or to install Ubuntu.

Extra info: When I try with Ubuntu 16 it start the graphic environment but when it arrives to choose which partition to install, the list appears empty.

Any help would be appreciate.

  • 2
    Did you check the integrity of the downloaded Ubuntu ISO before creating the bootable USB? – pomsky Jan 18 at 8:05
  • 1
    yes, checked it and matched – Another.Chemist Jan 18 at 8:17
  • 2
    All i see there are read-errors, either a invalid-download as pomsky suggested & you said okay, or the media used was faulty (or write-failed). Did you check your install media using the inbuilt function? (when the keyboard & person-in-circle type icons appear you hit space bar & should get a menu which includes option you need; the actual ISO you downloaded can change what you see, but that should be enough for you to find option I hope) – guiverc Jan 18 at 8:55
  • @guiverc yes, I created a new dvd and yes, check it and passed – Another.Chemist Jan 19 at 4:40
  • 1
    That startup looked OK, so it's probably a graphics problem now. Do you have Nvidia video? If so try adding the nomodeset word where you added the other words at the quiet splash (you may remove the quiet word for more information at boot time). – ubfan1 Jan 19 at 16:24
1

With the sort of errors you initially saw, the first thing to check is the ISO with a hashcheck, and then the media selecting the media check grub menu option. A memory check is the third thing to check. Since you did this, the media is OK, but if interrupts are not handled correctly, the program can get scrambled, resulting in all sorts of random errors. The noapic and nolapic options added to the line starting with "linux" in the grub menu item being booted change the way interrupts are handled, and apparently, allowed the program to complete.

The next problem is a video issue likely caused by proprietary video hardware. Until the proprietary video drivers are installed, adding the word "nomodeset" on the grub linux line allows the video to run, probably at a reduced resolution. If you immediately install the proprietary video drivers (e.g. for Nvidia, run the Software and Updates program, select the Additional Drivers tab, and select the current (tested) driver). If you don't want to do that, you can add the nomodeset word to the grub configuration by editing the /etc/default/grub and adding nomodeset to the line

GRUB_CMDLINE_LINUX_DEFAULT="nomodeset quiet splash"  

Then run

sudo update-grub  

to update the grub.cfg file, which controls the displayed grub menu.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.