0

When I try to access shares with pcmanfm-qt in Lubuntu 18.10, it only shows the / directory on the Lubuntu machine. I downloaded Nautilus, and it does not have this problem. Is there a fix in pcmanfm-qt? Alternatively, how can Nautilus be made default file manager in Lubuntu, and/or be given a menu entry or taskbar icon for one click start? Thank you for your help.

I set up a shared drive on my desktop running Ubuntu 18.10 which I would like to access from my laptop, on which I have installed Lubuntu 18.10. When I open PCMan and click on Network, the shared drive is visible. If I click on the shared drive, PCMan opens the Home directory on the laptop instead. If I perform the same operation with Nautilus, the shared drive is opened. Thanks for your attention.

  • 1
    In what way does not not access Samba shares? Can you please provide more information. I use NFS, but loaded an old NAS device that uses samba, and with pcmanfm-qt I could access my shares as I'd expect. For me I accessed it via path (for me it's quickest) which may not be how you do, or want to - but please explain. Lubuntu 18.10 is Qt based; Nautilus is GTK+ thus is wasteful of memory/resources and a very poor choice as a default. but please clarify. Sorry not sure what you meant by 'fiex in PACMan'' – guiverc Jan 18 at 2:57
  • Sorry for not being clearer about the problem. The spelling should have been "fix". – autumnleaves Jan 19 at 13:33
  • Here is the detail you request. I set up a shared drive on my desktop running Ubuntu 18.10 which I would like to access from my laptop, on which I have installed Lubuntu 18.10. When I open PCMan and click on Network, the shared drive is visible. If I click on the shared drive, PCMan opens the Home directory on the laptop instead. If I perform the same operation with Nautilus, the shared drive is opened. Thanks for your attention. I'm now trying to switch to SSH. – autumnleaves Jan 19 at 13:39
  • Please add the additional info to your question, as only a small number of users read comments (the more people who see it, the more chance of a fast & useful answer to you). How you access the share is not how I would, and I will endeavour to later boot an old 18.10 qa-test install & access a samba nas device (which won't have been setup thus may better reflect what you see). – guiverc Jan 19 at 23:14
  • I booted the Lubuntu 18.10 box, brought it up-to-date, and tried using pcmanfm-qt to view my old nas device (which has samba enabled) and it saw this box [19.04] & others, but not my nas. Yes clicking some had me view my (local) / drive which fits what you describe (only not Home). I tried adding dolphin (it uses Qt like Lubuntu and thus is far lighter than gnome's nautilus) but didn't get any further. Back in pcmanfm-qt I entered smb://buffalo122/buffalo (my device name; I didn't want to keep typeing IP address so buffalo122 was added to my hosts file) – guiverc Jan 20 at 0:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.