0

I'm trying to convert some old Windows 7 machines to Lubuntu to be used to rdp to our Windows Terminal Server. I got it setup so that the lubuntu account auto logs in, then it runs a script that auto connects to the terminal server. Ideally, I want the login prompt to be from Windows and not from Linux, but it's not necessary.

When I first setup Remmina, I could set the Security type to "RDP" and it would connect, then prompt for a login via Windows. After a reboot, that has stopped working . Just gives the error " Unable to establish a connection to RDP server 'server'". I know you're gonna ask for a log file, but after a little googling I honestly couldn't find a definitive source on where it is.

So the alternative is to just have it ask for the password before connecting to the server using NLA. My issue here is that it gives an option to save password and auto logs in as that user from then on if you check that box.I really don't want that option since people tend to jump around to different workstations. I can tell the users to not check that box, but I'm sure they will anyways.

I tried to make it so the file was "read-only" (made owner the admin account, made admin account the only one allowed to change it) but it seems like as soon as you start Remmina it changes those permissions. Bit stumped on this one and it's been a tough one to Google for sure.

I'm open to other RDP client alternatives too, Remmina just seemed pretty smooth up until now.

  • 1
    Try navigating to /home/$USERNAME/.freerdp folder and delete the file known_hosts. Next time you try to connect the file will be regenerated. Let me know if it works. – user68186 Jan 17 at 20:09

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.