1

There were no issues before, but today I started my computer and I removed the unstable OIBAF graphics drivers and tried to add stable OIBAF graphics PPA. I left for about 15 minutes and when I came back the terminal was stuck at the initial command without any output. It looked like this:

enter image description here

I thought this was an internet issue, but it wasn't. Then I canceled adding the PPA and tried to install it again but had the same issue (the apt-add-repository command does works but takes a lot of time to show any output. Everything was fine before --it took less than a minute to complete-- but now it takes more than 15 minutes).

I've also tried adding different PPAs but had the same issue.

My kernel version is 4.20.0

I've also built a kernel installed and removed but then there was no ppa related issue.

EDIT: There's more delay when I cancel the command with CTRL+C

  • I'd suggest trying again in a few hours - internet connection issues may not be limited to your computer/network, and it may be that some system between your computer and the PPA servers is overloaded – Charles Green Jan 17 at 18:10
  • @Charles Green No it is not internet issue at all. My laptop with mint connected to same network works fine. Also my computer is new so no problem of ports/wifi etc. it is just all repositories are slow. – Saurav Singh Jan 17 at 18:18
  • 1
    @pomsky I'd add a traceroute from me to launchpad (8 hops), but in comments that's a painful experience. – Charles Green Jan 17 at 19:00
  • 1
    I solved problem by deleting repositories with missing gpg keys – Saurav Singh Jan 21 at 9:54
1

I found the issue, it was due to other unsigned repository I added to my system because of this there is a lot of delay in adding PPAs. Simply remove those unsigned PPAs and problem will be solved.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.