7

I have a Asus R556L, running Ubuntu 18.04LTS on dual boot with Windows 10. The sata mode in the bios is AHCI.

Ubuntu works fine, but after working for a while, it goes to the black terminal screen with these errors, very similar to this post. Windows works for some seconds and then I have a blue screen error and the PC reboots.

When I get this black screen the computer doesn't respond anymore and I have to reboot with the power button.

After reboot, I got the log files from the two previous boots with

journalctl -o short-precise -k
journalctl -o short-precise -k -b -1

They can be donwloaded at last_reboot and previous_reboot.

There is one error that might be interesting (no usb device is plugged):

Cabirto kernel: usb 1-6: device descriptor read/64, error -110

And also some of the kind:

Cabirto kernel: print_req_error: I/O error, dev sda, sector 922702400

I booted from a live CD to make some fix with the hard drive unmounted:

I tried to run

sudo e2fsck -p /dev/sda5

Which returns

/dev/sda5: clean, 785130/39829504 files, 54124587/159286528 blocks

(translated from French)

I ran a quick smart test smartctl -t short /dev/sda and smartctl -l selftest /dev/sda which gives

Num  Test_Description    Status                  Remaining  LifeTime(hours)  LBA_of_first_error
# 1  Short offline       Completed without error       00%      3418

An extended smart test found no error.

Heres what fdisk -l shows (with loop devices removed):

Disk /dev/sda: 931,5 GiB, 1000204886016 bytes, 1953525168 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: CD049B10-7DBD-4B39-912A-D7956EF0AE6A

Device          Start        End    Sectors   Size Type
/dev/sda1        2048    1023999    1021952   499M Windows recovery environment
/dev/sda2     1024000    1228799     204800   100M EFI System
/dev/sda3     1228800    1261567      32768    16M Microsoft reserved
/dev/sda4     1261568  410861567  409600000 195,3G Microsoft basic data
/dev/sda5   666849280 1941141503 1274292224 607,6G Linux filesystem
/dev/sda6  1941141504 1953523711   12382208   5,9G Linux swap
/dev/sda7   410861568  666849279  255987712 122,1G Microsoft basic data

Partition table entries are not in disk order.    

Disk /dev/sdb: 7,5 GiB, 8015314944 bytes, 15654912 sectors
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x0006aec1

EDIT : until this morning Windows worked fine but now I have a blue screen error and the PC reboots.

Edit : when modifying the grub menu as suggested in the comments, the message in the black screen changes and there 'ata' lines appear.

EDIT : Solution In the end I sent my computer to ASUS technical services. They changed the motherboard. To what I understood, there was a connection problem. It was not a failing hard drive but filing wires or connectors.

[4]: https://i.sstatic.net/WI12t.jpgenter image description hereenter image description here

12
  • 1
    Can you clarify what your question is?
    – Leo
    Commented Jan 17, 2019 at 23:27
  • When I get the black screen I can't use my laptop anymore and I have to reboot it with the power button so I lose everything that wasn't saved. I would like not to have the black screen anymore
    – Cabirto
    Commented Jan 18, 2019 at 23:07
  • After reboot, can you try unix.stackexchange.com/a/345978/92929 to retrieve log messages from the previous boot? It might contain the actual error. Commented Jan 21, 2019 at 15:50
  • I edited my post with two logs from the last and previous boot. It seems that there is a sector error, but I don't understand what it means and I don't get why SMART didn't find it...
    – Cabirto
    Commented Jan 22, 2019 at 11:34
  • Do you use the drive over a usb hub, or is it directly plugged into the machine?
    – s1mmel
    Commented Jan 22, 2019 at 11:55

1 Answer 1

0

This is a hardware problem. Try to unplug the harddrive and put it in. Sometimes that does the trick. I know it is a laptop, but it should not be that complecated. If you can affort it get a new SSD and a USB-housing for your current drive and backup everything to the new SSD.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .