0

It looks like a bug but I am not sure which program is to blame..

In Plasma 5.12 the option to add global menus in window titlebar has been removed, but there is a panel widget that adds global menus to the panel, while global menus are still available in the window titlebar as a button.

"Global Menu" widget on the panel (Chrome menu):

enter image description here

Setting as indicated here (under System Settings > Application Style > Windows Decorations > (tab) Buttons)

enter image description here

brings global menus into a left-side button on the window upper margin; like for example in Chrome:

enter image description here

When any of these global menus are enabled, Libreoffice (6.0.7) has no menubar anymore. Adding the Menubar button in Libreoffice and using it has no effect.

enter image description here

But after disabling these two ways of displaying global menus, the menubar in Libreoffice comes back. These changes happen instantly in Libreoffice, no program restart needed.

enter image description here

So, it seems I cannot enjoy global menus and use Libreoffice properly in Kubuntu 18.04.

I read here that Plasma 5.14 will bring out of the box global menus for gtk applications (something that is available as "tech preview" in 5.13). So, absence of global menus for gtk apps in 5.12 is normal, but why should global menus for KDE applications would mean breaking non-global menus for Libreoffice?

Can anybody confirm this problem? Any ways around it?


enter image description here

Libreoffice is 6.0.7.

The same problem after upgrading to 6.1.4.

Installing gtk3-nocsd to disable client side decorations didn't help either (Libreoffice was not using those anyway I guess.).


Update:

18.10 with Plasma 5.13.5 displays the same behaviour.

Plasma 5.14.15 (installable in 18.10 with the Kubuntu backports PPA) adds global menus for GTK applications, so the Libreoffice menus are accessible in the panel or the window button. (This works fine with the standard interfaces, but with the experimental interfaces the global menus may disappear randomly.)

0

This is only a workaround - I will not mark it as solved, as I'm hoping for answers on how or at least when this could be fixed.


Workaround: while this will not bring the standard menubar (when global menus are enabled as indicated in the question), it will make Libreoffice usable by providing access to its menus in one of the user interfaces that become available if experimental features are enabled.

Global menus have to be disabled (as panel widget or as window button) in order to access Libreoffice menus of the standard interface.

Enable experimental features under Tools - Options - Advanced.

enter image description here

Then go to View - User interface and select of the UIs from the lower part of the list.

enter image description here

Each of them is different (somewhat similar to the different versions of msoffice), but they all provide access to the menus in various forms. For example, the "Tabbed compact" UI provides menus in tabs and shows a button to the right-upper corner to access among others the different UIs.

enter image description here

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.