0

Using Gparted on a live Ubuntu flash drive, I shrank the SSD partition on which my Ubuntu 18.10 installation sits. I did not move it to the right, just shrank it, leaving unused space to the right. It still had plenty of empty space even after the shrink.

Grub worked, I booted up, logged on to my user account, and had trouble launching programs.

I rebooted, and after grub, Ubuntu did not come up. I was staring at a purple screen with no text.

I rebooted into safe mode, and got a message like /dev/sda?: UNEXPECTED INCONSISTENCY; RUN fsck MANUALLY

This issue is repeatable. Every time I shrank the disk, I had the same issue.

Eventually I ran fsck manually on the specified sda (don't remember which), and clicked "yes" every time, and that fixed it. No issues since then.

So my question is: why does this happen, and how can it be avoided?

  • No answers... am I just unlucky, and other people don't ever get errors like this after shrinking a Linux partition? If it would be boot error, I wouldn't be so surprised. But it was an error at a later stage, it prevented the OS from loading. For someone coming from Windows, that's weird. – shmu Jan 18 at 6:01

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.