0

My laptop has the windows 10 system and I have installed the subsystem Ubuntu. I have installed Rstudio but when I run it "QXcbConnection: Could not connect to display Aborted (core dumped)" will be shown. Could anyone tell me how can I run Rstudio on my Linux subsystem? Thank you

0

WSL (Ubuntu) does not have a GUI!

The Windows Subsystem for Linux (WSL) is only command line. That means it can only run programs that have a text based interface. R for Linux is text based. Rstudio is a graphical user interface for R. You may be able to run R in WSL. I have not tried it.

However, without considerable tweaking it is not possible to run any software in WSL that needs a GUI. See What's the easiest way to run GUI apps on WSL as of 2018?

Both R and Rstudio is available for Windows. You may want to use those versions.

Hope this helps

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.