1

I'm on Ubuntu 18.04 and noticed sometime that I cannot open any folders from the icons on my desktop anymore. The following error is given in /var/log/syslog when trying:

$ cat /var/log/syslog | tail -3
Jan 16 17:59:51 drstoop-pc kernel: [  657.870793] [UFW BLOCK] IN=wlp112s0 OUT= MAC=01:00:5e:00:00:01:c4:71:54:33:0a:b0:08:00 SRC=192.168.0.1 DST=224.0.0.1 LEN=36 TOS=0x00 PREC=0x00 TTL=1 ID=0 DF PROTO=2 
Jan 16 18:00:33 drstoop-pc signal-desktop.desktop[4016]: {"name":"log","hostname":"drstoop-pc","pid":4016,"level":30,"msg":"Sending a keepalive message","time":"2019-01-16T16:00:33.885Z","v":0}
Jan 16 18:00:34 drstoop-pc nautilus-deskto[4026]: cannot open folder on desktop, freedesktop bus not ready

Nevertheless opening the desktop folders works from a nautilus window and also after killing and restarting nautilus-desktop. Restarting only helps till the next reboot:

$ killall nautilus-desktop
$ nautilus-desktop &

But I'd prefer a bug-fix, not a workaround... any ideas? THX!

Further logs

Kill, restarting and opening a folder from a desktop icon results in following /var/log/syslog:

Jan 16 18:09:48 drstoop-pc dbus-daemon[3099]: [session uid=1000 pid=3099] Activating service name='org.gnome.Nautilus' requested by ':1.21' (uid=1000 pid=3228 comm="/usr/bin/gnome-shell " label="unconfined")
Jan 16 18:09:48 drstoop-pc dbus-daemon[3099]: [session uid=1000 pid=3099] Successfully activated service 'org.gnome.Nautilus'
Jan 16 18:09:48 drstoop-pc dbus-daemon[1927]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service' requested by ':1.106' (uid=1000 pid=6160 comm="/usr/bin/nautilus --gapplication-service " label="unconfined")
Jan 16 18:09:48 drstoop-pc systemd[1]: Starting Hostname Service...
Jan 16 18:09:48 drstoop-pc dbus-daemon[1927]: [system] Successfully activated service 'org.freedesktop.hostname1'
Jan 16 18:09:48 drstoop-pc systemd[1]: Started Hostname Service.
  • The next Ubuntu version 19.04 will drop support of desktop folders and use a gnome-shell extension instead. Awaiting this, or a real fix, you could workaround by having your two commands autorun when you login. – vanadium Jan 16 at 17:52
  • thx, good info... waiting sounds like an efficient fix ;) – drstoop Jan 18 at 5:25
  • I have the same problem, but your solution $ killall nautilus-desktop $ nautilus-desktop & does not work for me... – Francesco Boccardo Feb 2 at 10:39
  • @FrancescoBoccardo: on which file system have you installed your ubuntu? i experienced this issue with lvm and btrfs. also check if you have nautilus added to your Startup Applications. This is where my bug is triggered. – drstoop Feb 8 at 11:01
  • @drstoop thank you for your help, but I finally solved the issue. The problem was that I still had some leftovers of an old installation of MATE desktop, – Francesco Boccardo Feb 9 at 10:17
0

Remove nautilus form Startup Applications

I could not solve the problem, but I found the trigger, 'disabled' it & reported the bug: Folders on the Desktop only cannot be opened when nautilus is set for 'boot-launch' in Startup Applications. As soon as I remove the nautilus from the Startup-app-list and reboot, the folders open normally. This bug is reproducible & I experienced it on Ubuntu 18.04 and 18.10.

At least on now can circumvent the bug till it's fixed.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.