12

I want to avoid my windows snapping to the edge of my screen when resizing and moving, but it doesn't seem to work.

I am running GNOME 3.28.2 on Ubuntu 18.04.1 LTS. I see no options for snapping when I go through the native Settings app, I have gnome-tweaks in which I see no options for snapping, and I have Compiz config which does have options for snapping, but unchecking it has no effect. Which has me wondering if Compiz config is outdated for GNOME 3 or something? My apt says it's the latest version, 1:0.9.13.1+18.04.20180302-0ubuntu1.

So, can I turn off window snapping in some alternative "hacky" way?

Edit

The suggested duplicate thread didn't solve it for me. I turned off the setting in Dconf editor as per the accepted answer, but they still snap. It seems quite inconsistent, and i can't figure out if it depends on the type of application or size of the window or what, however the title bar on top always snaps, whereas sides sometimes don't.

5
  • Possible duplicate : askubuntu.com/questions/907797/…
    – ob2
    Commented Jan 16, 2019 at 15:25
  • 1
  • Which one did you turn off using dconf editor?
    – pomsky
    Commented Jan 16, 2019 at 16:16
  • If you mean the commands from your other accepted answer, i ran both. I even tried it as sudo now, just in case, it still snaps. But for example the terminal window snaps differently than Firefox. If i don't let the edge of terminal quite touch the edge of the screen, it will allow me to leave it close to it. Once they touch, i just have to drag away far to unsnap it. But for Firefox i can never leave it close; if i leave it close and let my mouse go, it adjusts the position and snaps it to the edge. Commented Jan 16, 2019 at 17:03
  • 2
    "I even tried it as sudo" is not a good idea. Running things with sudo could alter permissions of files/folders in your home directory thereby making them inaccessible to you as a normal user.
    – DK Bose
    Commented Mar 31, 2019 at 14:07

3 Answers 3

5

You have probably found the solution by now, but just in case you have not yet found it or some one else is interested. The gnome-tweaks option you are looking for is called 'Edge Tiling' located in the Windows section.

2
  • 1
    You're probably talking about newer release(s) of Ubuntu, but the question was originally asked for Ubuntu 18.04 which does not have this specific option.
    – pomsky
    Commented May 26, 2020 at 13:28
  • Oh! Thank you. @I_Ranger
    – lngs
    Commented Jul 1, 2021 at 11:42
0

In KUbuntu v20.04 i do:

Disable:

[x] Screen Edges > Maximize dragged on top edge

A console solution (not tested by me): https://askubuntu.com/a/1029186/1017209

1
  • 2
    Kubuntu does not use the Gnome 3 desktop environment.
    – Levente
    Commented Apr 13, 2021 at 17:26
0

What worked for me was deselecting

\CompizConfig Settings \Window Management \grid

Works great! Now windows go where I want them and when I want them to be there :)

4
  • What desktop environment do you use CompizConfig with? Gnome 3? Is it still relevant / supported?
    – Levente
    Commented Apr 13, 2021 at 17:28
  • Running Linux Mint 19.3 with Mate as the desktop manager Commented Apr 14, 2021 at 22:06
  • looks like i have gnome 3.28 Commented Apr 14, 2021 at 22:13
  • MATE is not Gnome 3...
    – DaVince
    Commented Dec 14, 2021 at 14:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .