0

Ever since upgrading from 14.04 to 16.04 (uneventfully), I am getting a warning popup on login titled:

Temporary Guest Session

with the message:

All data created during this guest session will be deleted when you log out, and settings will be reset to defaults.

However, I am logging in as myself (username, password). And in fact changes to my account (desktop, browser history, etc.) are saved between sessions.

Why am I getting that warning and how can I remove it?

  • You may want to edit your question and provide more details. Such as, which version of Ubuntu did you upgrade from? If there were any errors and interruptions (such as power failure) during the upgrade. – user68186 Jan 16 at 16:59
0

You can disable that dialog by creating the file /etc/guest-session/prefs.sh and inserting the line:

touch $HOME/.skip-guest-warning-dialog

https://help.ubuntu.com/community/CustomizeGuestSession#Disable_startup_dialog

  • Thanks. According to the link you provided, this is for disabling the startup dialog for guest accounts. I'm not a guest, I'm a registered user with a /home/<my-username> directory. The question perhaps should be: why is my account being associated with a guest user? There seems to be something in my account settings that makes Ubuntu think I'm a guest on login. – Cosmo Jan 16 at 15:20
  • @Cosmo: Right. That sounds weird, and I have no explanation or theory offhand. Nevertheless you may want to try the above suggestion. Can't hurt, at least... – Gunnar Hjalmarsson Jan 16 at 17:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.