0

I'm running 18.04 on a new Thinkpad X1 Carbon (6th gen) laptop. I can connect other monitors to the HDMI port (a random TV in a hotel room; an Asus 27" 1080p monitor) and everything works as one would expect: the "Display" settings chooser comes up, allows me to pick a configuration, and stuff shows up on the big screen. I've been connecting this particular LG monitor to a Thinkpad T440p laptop for years without any incident of weirdness ever.

I'm not using the new desktop server ("Wayland"? whatever it is); I'm using Xorg. I'm also running the xfce4 desktop. Again, this is precisely the way I've been going for years on the old machine, and also to reiterate the new laptop works fine with other monitors.

With the X1, however, plugging in the LG monitor works only about 1 in 15 tries. (By "works" I mean acts like other monitors.) Most of the time, the system goes into some sort of weird fugue state. The X server becomes unresponsive (the mouse cursor moves, but that's about it). Usually nothing shows up on the external monitor, but every once in a while I'll get the desktop background (but nothing really works).

I can flip over to a console (ctrl-alt-f1) and I can log in, and the system seems responsive. Indeed, usually when the X world is messed up the external monitor, after a short delay, will show the low-level console!

I can kill the Xorg process, and it'll be started up again. Often (not always), even when things have been screwed up, when the new X server wakes up it gives me the login screen on both the laptop monitor and the external monitor. I can type in my password to the display manager dialog and see the hidden password dots echo on the external monitor, but when the login sequence completes both monitors go dark, but only the laptop comes back. And generally the X server is wedged up and nothing really works.

Rebooting completely does not necessarily help, whether I do it with the external monitor plugged in or not.

And, sometimes, it all just works.

I've tried watching for weirdness in /var/log/kern.log and dmesg, but I've never seen anything that looked interesting. The only stuff that seems unusual to me are some i2c messages about "NAK timeout" and sometimes about a bad EDID on the HDMI monitor (though that doesn't always happen).

I know that this is a long-shot question, but if anybody has any clues as to what this laptop is doing I'd be thankful.

Oh and of course I'm happy to attach xdpyinfo or xrandr or whatever output to the question, but because the behavior is not very consistent I'm not sure how interesting that'd be.

0

I think the problem was the HDMI cable itself. I don't know what exactly is wrong, but I woke up this morning remembering a lesson some smart EE people taught me (or tried to teach me) about weird problems: always start with the cheapest components.

Tried one of the cables I used to hook up to other monitors and sure enough everything's fine.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.