0

Ubuntu 18.04 is up to date. On Firefox, browsing seems to spend all of its time "looking up xyz". Ubuntu 16.04 was much better. On the same hardware using Fedora 28 and Firefox, the web browsing time is excellent.

Tried Chrome, worked great. Reloaded Firefox, same results. Firefox version: Quantum 64.0 Mozilla Firefox for Ubuntu. Canonical - 1.0.

Tried using DNS servers Google and openDNS. Not much help.

I am using x86_64, 4.4 GHz clock, 16 GB memory, SSD drives, 60 Mbit internet connection.

Until this gets fixed, I will have to use Fedora.

  • 3
    How strange, because my 18.04 with Firefox is very fast...so this does not seem like a universal problem. Please narrow the scope of your problem to determine if it's a networking stack problem or a Firefox problem.. "Not much help" does not really tell us anything. – user535733 Jan 15 at 18:05
  • Tried chrome, worked great. Reloaded firefox, same results. Will stick with chrome. – DougT Jan 15 at 19:10
  • Can you include the firefox version in your question? – Charles Green Jan 15 at 19:21
  • The firefox with Ubuntu and my download are the same version: Firefox Quantum 64.0 Mozilla firefox for Ubuntu. Canonical - 1.0 – DougT Jan 15 at 21:05

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.