0

I have upgraded my ubuntu to latest (18.04) on a dual boot HP Pavilion. The windows 10 partition has been unbootable for some time and now both partitions are unbootable. After the ubuntu upgrade completed, I had a message saying that my machine was in an unstable state with no instructions on what to do.

I tried to download new software, but was not able to because of a grub error message. I followed the instructions here to fix the error: What can I do to fix this error on grub-efi? (these instructions to be more specific: sudo apt-get purge grub* sudo apt-get install grub-efi sudo apt-get autoremove sudo update-grub)

The next time I restarted my computer I had a blue screen stating "Verification failed: (0X1A) Security Violation". After pressing enter I get a screen with "Shim UEFI Key management". I can then enter into a "Perform MOK management" screen with 3 options:

1) Continue boot 2) Enroll key from disk 3) Enroll hash from disk

Option 1, will display the security violation. Option 2, with every possible efi will not work., Option 3, with every possible efi such as grubx64.efi, shimx64.efi, mmx64.efi will fail to enroll the key.

Current state: I can't get GRUB or BIOS. Pressing F10 for example, should bring up BIOS on my machine, I see the text on the bottom saying BIOS menu, but no menu ever comes up. Pressing ESC will pause the startup, but there is no way to get out of that screen.

Things I have tried: 1) Updating BIOS by pressing windows + b, it goes through the process and then fails 2) Uploading BIOS to usb stick following instructions on HP website, no way to get to stick 3) Going through every single efi file with every option on MOK management screen

Not sure what to try next or if this something that can be recovered from.

EDIT: My goals right now 1) get to my data and back it up somehow 2) wipe out the system to start fresh in that order.

SOLVED: I was able to get into my BIOS by disconnecting the hard drive, booting up the system and pressing F10. Through the BIOS menu I could then disable Secure Boot. (Unfortunately, I have already reformatted my Linux partition). Hope this helps someone else who experiences the same issue.

  • Have you tried turning off UEFI Secure Boot. And an UEFI update from HP usually reverts all UEFI settings to defaults, so you have to turn it off again and change any other settings. I keep a list as I have 7 to 10 changes, some required & some optional that I have in UEFI. Do you have proprietary drivers like nVidia or WiFi? If Secure boot on, then mokmanager will ask you to provide Secure Boot key as Canonical cannot. You should only do that with drivers you trust. – oldfred Jan 15 at 15:45
  • I cannot boot into my machine at all, I cannot go past those blue screens, how would I turn off secure boot or update UEFI from HP? – gwen_stacy Jan 15 at 17:40
  • It can be recovered from, but the effort may not be worthwhile. "An unstable state" or "An inconsistent state" often means that you have made unwise decisions in the past. If you don't know what those decisions were, then it may be easier to backup your data to a separate media and then to clean-install a fresh version of Ubuntu. Depending upon the changes you made, though, it may not. – user535733 Jan 15 at 17:54
  • How do I get to my data if I can't boot my machine? (Also none of the F10, etc keys work or ESC). Could you give me some concrete suggestions? – gwen_stacy Jan 15 at 18:09
  • You can try full cold boot: askubuntu.com/questions/652966/… You need to turn off fast boot in UEFI which is different than fast start up in Windows. – oldfred Jan 15 at 19:25

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.