0

I'm currently trying to set up VirtualBox with Ubuntu (18.04.1-desktop-amd64) on macOS, however, I'm not able to get the menu bar to appear no matter what fixes I try to apply. So far I have tried multiple fixes from Stack Overflow and the VirtualBox forum, including;

Editing the VirtualBox.xml file to include (as mentioned here):

<ExtraDataItem name="GUI/Toolbar" value="true"/>

Tried inserting this manually via the editor, as well as over the console via;

VBoxManage setextradata global GUI/Toolbar true

After inserting the line (via editor or console) the file remains unchanged when restarting VirtualBox and restarting the Ubuntu-VM, though the menu bar doesn't appear. When shutting down the VM and closing VirtualBox afterwards, the file gets recreated and the inserted line is removed.


Additionally I've tried using this console command:

VBoxManage setextradata global GUI/Customizations MenuBar,StatusBar

which ends up adding the following line to VirtualBox.xml file:

<ExtraDataItem name="GUI/Customizations" value="MenuBar,StatusBar"/>

It also doesn't bring up the menu bar, though, for some reason this line always remains in the .xml file even when it gets recreated, as described above.


I've also tried;

  • bringing up the mini menu with Host+Home - but it doesn't open the mini menu for some reason
  • right click on the status bar to open the menu bar, but it only displays the options for the status bar settings and to toggle the status bar
  • activating the menu bar under the VM's UI settings, here I can activate all the individual menu bar items, but there is no [ ] tick box to activate the menu bar (screenshot)
  • tried all these solutions in full screen mode and window mode, while making sure that the VM is not in scaled mode - while doing so the status bar is visible but the menu bar doesn't appear

I've been trying to solve this issue for the past 2 hours and read through all relevant Stack Overflow and VirtualBox forum posts related to this issue, but no solution has worked out so far. Also reinstalled VBox and Ubuntu multiple times but no success. Does anyone have any idea on how this issue can be resolved?

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.