0

I'm using ubuntu 18.10. In the past I probably made a change for my bluetooth to not start on startup but I do not remember the change. Now, I want to restore it back to normal but I couldn't find a way. Every time I start-up my system the bluetooth icon is not even appearing. When I start it from the applications it says daemon not running etc. I checked "blueetoth/main.conf" but "AutoEnable=true" exists. If I do

 sudo service bluetooth start

it works but when I restart my computer, the problem is back again.

Edit:

sudo rfkill unblock bluetooth

This didn't solve the problem, too.

  • 1
    I might not be able to fix your problem but i can offer you an workaround: ( crontab -l ; echo "@reboot sudo service bluetooth start") | crontab - Run this in your terminal to set a cronjob that restarts your bluetooth service on reboot. – Patient32Bit Jan 15 '19 at 8:46
1

You just need to use the following command in order to enable bluetooth service from systemd boot system.

sudo systemctl enable bluetooth
| improve this answer | |
1

I am on Ubuntu 20.04. the problem was that I could not turn on bluetooth

it was solved by the command:

sudo /etc/init.d/bluetooth start

I had to do this every time I booted into ubuntu. to make it permanent when booting into ubuntu I used the command mentioned above:

sudo systemctl enable bluetooth
| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.