I've recently installed Cyanogen Mod 9 on my HP Touchpad tablet, but I'm encountering problems when trying to access it from my Ubuntu laptop (Ubuntu 11.10, Gnome-Shell, Nautilus).

I've first tried accessing it via PTP as suggested here. Ubuntu will recognize the Touchpad as a digicam and only grant me access to two directories: "DCIM" and "Pictures".

I then tried accessing the tablet via MTP using this post on OMGUbuntu!. Ubuntu will connect to the tablet, but only grant me access to a folder named "Playlists".

  • OP are you still looking for an answer? If so, you may need to repost your question as this is flagged for closure. Regards,
    – Ringtail
    Apr 7, 2012 at 0:12
  • 1
    this is working for my CM touchpad on 11.10. do you get any error message when typing android-connect?
    – Simon B
    Apr 11, 2012 at 12:35
  • 1
    ...also make sure all your packages are up to date , since earlier versions of mtp in 11.10 were buggy
    – Simon B
    Apr 11, 2012 at 12:46
  • once had to reboot my android device to be able to remount on ubuntu ...
    – type
    Jun 19, 2012 at 14:51
  • Maybe this is a solution: Connecting Galaxy S3 (I747) to Ubuntu 12.04.
    – BuZZ-dEE
    Jan 30, 2013 at 16:27

11 Answers 11


It sounds like you are looking for USB Mass Storage mode. According to this forum thread, that doesn't exist yet in Cyanogenmod 9: http://forum.xda-developers.com/showthread.php?t=1582319


You can access your files by setting up an ftp server on the tablet, which is easy and allows you to access your files with Nautilus. The Swiftp app is an abandoned project but should still work.

You can mount the tablet over ssh by using sshfs in ubuntu with a command like: sshfs root@ /media/android -p 2222 after following my instructions here to set up an ssh server on your tablet. (SSHelper is an easy to use implementation). This method will work over usb too.

Last but not least: adb. It has a few quirks when comes to moving files around and it requires Java and the android sdk to be installed, but I always use it. Works over wifi too.

  • Definively the way I wanted to go, but on my rooted device (GalaxySIII running CM9), although ssh works just fine, sshfs will reply with: read: Connection reset by peer. Ideas?
    – mac
    Oct 12, 2012 at 19:15

Try running the program
"Clockwork Tether"
Then try useing "Samba File sharing"
Thats what i would do in a pinch. But as for Mass storage not mounting, thats a rom issue.


The easiest way to share files with Android devices is File Expert (free) - it has the option 'Share Contents -> Ftp/http' which will start an ftp or http server that you can then connect to from your other devices over the air. It also includes an ftp and sftp clients which you can use in case you have an ftp or ssh server running on your desktop.it works over the air so there is absolutely no need to use cables. Even in cases when you don't have a router or wifi internet you can still transfer files over the air simply by enabling wifi hotspot mode in your Android device and then connecting to it from your notebook.

The Android version of Total Commander also has an ftp client plugin that can be installed from market (both the app and the plugin are free).


IMO, the easiest way to get files synced with Android-devices is to establish an sftp-connection with your Computer. Just run

sudo apt-get update
sudo apt-get install openssh-server

to get an ssh server on your computer. Now download and install AndFTP on your phone and start it. The first time you'll have to get several config done but one time configed this is a fast and easy way to get a connection and you don't even have to connect the device via USB.

Works only if both Computer and device are in the same Network!


In addition to the FTP options already mentioned, there's an app you can install on the Touchpad called "Software Data Cable" by Dami App that sets up an FTP server that can allow access to root folders and all that as well as the normal ones. It defaults to requiring no login, but you can set one.


i with my android device use: sshdroid a simple and efficent app that run an ssh server on android (for me 2.3.5) sshdroid need superuser setup you android app "sshdroid" with ip adress and port

in your ubuntu machine you need openssh-server, refer in the net for info's and how to, create after the installing you ssh public key, add this in you sshdroid apps with the proper menu, if all work fine, simply open nautilus-->file-->connect to server ssh server put the ip of your android device put you android ssh port and connect, nautilus ask you for some confirmation, you can save this connection in your bookmarks. (remember android with the same ip adress for every connection-otherwise you bookmark don't work). it's simply, secure, crypted connection and complete browsing of you android paths.


When I connect my CM9 Transformer to 12.04 with Gnome Shell it does not connect until USB Debugging Mode has been disabled. I then see two drives, one for internal memory and another for my removable card.



If you want to transfer files between your computer and your tablet, get aafm, an application written to work around MTP issues with Linux.

Android ADB File Manager - A command line + GUI (GTK based) Android ADB-based file manager. https://github.com/sole/aafm


With the HO Touchpad first set it to USB mode, then use the charger/USB cable and plug it into your main computer.

Ubuntu should automount it as a USB device, which you can browse and move files between graphically, unless you prefer the command line, in which case you'll have to identify the automount directory name and path to it.


I think you want to turn on the MTP button and have things magically happen, just like they do in other operating systems.

I encountered your same problem following the top-voted instructions: only got "Playlists" visible. I then did the following instructions here and the whole thing seemed to work fantastically and very easily.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.