0

I have read more than 15 pages where people expose their difficulties, discuss and teach how to install the Nvidia or Nouveau graphics driver in Ubuntu 18.04. I tried all the suggestions that I found. It is now one week since I began trying this, so frustrating (what did I do to Nvidia or Ubuntu to deserve this? I have tried, among others, the 3 installation methods suggested here.

I can't make Ubuntu Mate use the Nvidia GPU even with Nouveau driver; it always uses the intel driver/board.

Probably the most important information that I receive shows up when I try to manually install the proprietary graphics driver that I downloaded from the Nvidia website. Here it is:

ERROR: Unable to load the kernel module 'nvidia.ko'.  
This happens most frequently when this kernel module was built against the wrong or improperly configured kernel sources,   
with a version of gcc that differs from the one used to build the target kernel,   
or if another driver, such as nouveau, is present  
and prevents the NVIDIA kernel module from obtaining ownership of the NVIDIA GPU(s),   
or no NVIDIA GPU installed in this system is supported by this NVIDIA Linux graphics driver release.

Secure Boot is disabled. Kernel is 4.15.0-43-generic.

I deleted any blacklist mention to Nouveau or Nvidia in /etc/modprobe.d/.

In the window called by software-properties-gtk I choose nouveau or any version (390 to 415) of Nvidia driver, and it accepts and downloads many files without any error, but the computer still uses the Intel video controller.

P.S.: I tried to post the output of several bash commands that show important information about my hardware and Ubuntu installation but this forum prohibits it.

$ gpu-manager 
last_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
new_boot_file: /var/lib/ubuntu-drivers-common/last_gfx_boot
can't access /opt/amdgpu-pro/bin/amdgpu-pro-px
Looking for nvidia modules in /lib/modules/4.15.0-43-generic/updates/dkms
Found nvidia module: nvidia.ko
Looking for amdgpu modules in /lib/modules/4.15.0-43-generic/updates/dkms
Is nvidia loaded? yes
Was nvidia unloaded? no
Is nvidia blacklisted? yes
Is intel loaded? yes
Is radeon loaded? no
Is radeon blacklisted? no
Is amdgpu loaded? no
Is amdgpu blacklisted? no
Is amdgpu versioned? no
Is amdgpu pro stack? no
Is nouveau loaded? no
Is nouveau blacklisted? yes
Is nvidia kernel module available? yes
Is amdgpu kernel module available? no
Vendor/Device Id: 8086:3e9b
BusID "PCI:0@0:2:0"
Is boot vga? yes
Vendor/Device Id: 10de:1c8c
BusID "PCI:1@0:0:0"
Is boot vga? no
Error: can't access /sys/bus/pci/devices/0000:01:00.0/driver
The device is not bound to any driver.
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Skipping "/dev/dri/card0", driven by "i915"
Found "/dev/dri/card0", driven by "i915"
output 0:
    card0-eDP-1
Number of connected outputs for /dev/dri/card0: 1
Does it require offloading? yes
last cards number = 2

I couldn't open /var/lib/ubuntu-drivers-common/last_gfx_boot for writing. Error: can't write to /var/lib/ubuntu-drivers-common/last_gfx_boot

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.