0

This question already has an answer here:

Update: I originally flagged this as a "Lock Screen" problem. But with the help from @Dennis, I came to understand that the problem I describe below could be much better defined as a "Screen Shield" issue. Many thanks to @Dennis because I was getting ready to gouge my eyes out.


Original problem description:

I feel like I have had this problem before and I can't remember how I ultimately solved it. No matter what I do, when i close my laptop lid, it locks the screen. Except that it's not a lock screen, I don't have to enter my password, I just have to hit escape. That's annoying enough, but sometimes hitting escape doesn't work and I have to ssh into my laptop and kill X.

I have edited my /etc/systemd/logind.conf, here are the relevant edits:

 39 HandleLidSwitch=ignore
 40 HandleLidSwitchDocked=ignore
 41 IdleAction=ignore
 42 LidSwitchIgnoreInhibited=no

(all other line items in the logind.conf are commented out and I ran sudo systemctl restart systemd-logind or rebooted after)

I have installed tweak and disabled suspend with laptop lid closed.

I have made the recommended changes in the power section in Settings.

I have even installed Caffeine and enabled it.

Nothing matters, it still puts up that pseudo "not really a lock screen" screen when I close my laptop. And again, 25% of the time I have to kill X because I can't get out of it.

To make matter worse, it only goes into the lock screen about half the time, and I am unable to discern a pattern.

Much anger, please help.

Update: I tried the tip listed at How can I disable all locking in 14.10?

Still didn't work.

marked as duplicate by pomsky, karel, Kulfy, Elder Geek, Eric Carvalho Jan 15 at 13:48

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • 1
    Having a hard time picturing exactly, are you talking about the gnome screen shield that you can normally dismiss by swiping up with the mouse (or ESC)? – Dennis Jan 14 at 21:46
  • @Dennis - yes, I think so. I must confess I do not know the exact name of the screen that appears, but your description sounds right. – Robert Baker Jan 14 at 21:47
  • 1
    I think knowing that will be a big start if you search "disable gnome screen shield" there are tons of comments and suggestions from complex to simple. I just installed an extension that I can't recommend because I don't really know if it works. When you have to restart X, does the swipe up with the mouse not work? Just in case the extension is at extensions.gnome.org/extension/672/disable-screen-shield – Dennis Jan 14 at 21:54
  • 1
    I am going to give you what may, or may not, be a hint that could help you. I had a similar problem disabling the touchpad on my wife's laptop. I used xinput to disable it, but the problem I had was that the device id number of the touchpad changed at every boot. This meant that my original script worked randomly. I see a 'sleep button' listed in the xinput --list output on her laptop, perhaps this is the lid button? Anyway, I wrote a script that runs at logon to get the device number of the touchpad and then disable it. Perhaps you could do the same with the 'sleep button' if you have one. – Organic Marble Jan 14 at 22:33
  • 1
    @Robert Baker I know exactly what you mean and I felt that way with the original switch to gnome, but I have to admit I'm getting over it. I have tons of things I can play with, try, and learn. I have finally embraced the notion that gnome is extensible for a reason. I like what Ubuntu does to it and I don't mind using the tweaks of really creative people. – Dennis Jan 14 at 22:33
1

The names I have seen for this are "Gnome Screen Shield" and "Gnome Screen Curtain" it seems to be unrelated to the lock screen though judging by the amount of comment around the web available in searches, disabling it is a fairly common desire. On Ubuntu 18.04.1 with gnome 3.28.2 there is an extension that is working for me. I have disabled the lock screen and turned on the following extension. https://extensions.gnome.org/extension/672/disable-screen-shield/

  • 1
    Yeah, I guess knowing the actual NAME of the screen I was raging at might have been helpful in solving the problem on my own. Your extension seems to be working, and even if it eventually fails, at least I know WTF I am googling for. – Robert Baker Jan 14 at 22:35
  • Update: that didn't work. I just saw the "shield screen" again. – Robert Baker Jan 15 at 2:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.