3

This question already has an answer here:

I've been using 18.04, along with GNOME for a while now. It took a while to get used to it after being so used to Unity, but now I really don't enjoy Unity. The only feature I enjoy from it, is removable drives in the dock. Anyway: I can't log in suddenly, unless I use the gear to select Unity, or some odd thing called AfterStep. And when I say suddenly, I mean: one night I can log in, the next morning I can't.

And I really don't want an answer telling me to just use Unity, because I don't want to. My problem is that I can't use GNOME. I've seen things about gdm3 being broken, but I don't know whether or not that applies.

Another big thing to note is that, I can log in to another (seldom used) administrator account I created about a month ago, using the Ubuntu login (GNOME), and it works fine. Assuming the reason I can't log in to my main account is a settings problem is there any way I can just copy over these GNOME settings from the user account that works?

And to clarify, when I say can't log in, I mean I am stuck in a log in loop where after entering my password and waiting a minute, it just kicks me back to the login screen.

And finally, I have tried many combinations of uninstalling, and reinstalling gdm3, and lightdm, to no avail obviously.

EDIT: Addressing the possible duplicate of Ubuntu gets stuck in a login loop
This was actually the first or second post I found, and I followed the steps in the accepted answer, however it did not fix my problem. One thing of note to me, is that all the files mentioned already had the proper owners.

EDIT 2: I tried many of the non-accepted answers, for an hour or two, and none of them worked, however I did get my login working again.
I'm still not 100% on what caused the issue, but I decided since it was still very new, that I would try to see if I could uninstall recently installed packages. I found on Google that I could use things like history | grep " install " and grep " install " /var/log/dpkg.log to see recently installed packages and recently run commands with the string "install" in them. I started uninstalling pretty much everything that was installed in the last 5 days, restarted my computer, and it worked. So while I haven't nailed down exactly what caused the issue, I can at least report the issue as fixed.

marked as duplicate by JoKeR, karel, Eric Carvalho, Elder Geek, Zanna Jan 15 at 16:22

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • @JoKeR I have addressed this in my edit, thank you. – Magicrafter13 Gaming Jan 14 at 18:59
  • 1
    Even though the problem didn't occur immediately after upgrading to 18.04, I think your system is choking on gdm3 login display manager because it's too heavy. Unity uses lightdm by default instead of gdm3, and that's why it still works in my opinion. – karel Jan 15 at 3:02
  • 1
    Welcome to AskUbuntu! you'll note that the accepted answer in the called duplicate isn't the only answer. Clearly it worked for many, however there are other upvoted answers there that worked for a few. Your problem might be covered on one of those. – Elder Geek Jan 15 at 13:53
  • 1
    @ElderGeek I won't lie, I hadn't tried many other of the answers, and thank you for being kind with your comment. Even though none of the other answers I tried worked, I admit that I should have tried some of them before posting either way. – Magicrafter13 Gaming Jan 15 at 20:50
  • 1
    I don't think this is a duplicate. I just experienced precisely the same thing -- apt update, restart, and suddenly this behaviour -- cannot login anymore (my regular desktop background flashes briefly then I get logged back out), only Unity works. Something in the update messed something up. @Magicrafter13Gaming if you do figure out what the culprit was, would love to know! – edsko Jan 17 at 11:31

Browse other questions tagged or ask your own question.