48

Maybe I'm doing something wrong, but shouldn't the commands (run separately)

notify-send -t 1 "test"
notify-send -t 1000 "test"
notify-send -t 10000 "test"

Have different timeouts? The first being nearly instantaneous, the second one taking 1 sec and the third 100 seconds. In all cases it seems to take about six seconds.

Is there a way around behaviour? As the developers label this as a "feature" instead of a bug, I would like some alternatives...

  • 1
    yes they do I confirmed – Ringtail Mar 7 '12 at 21:43
  • For me it works as expected using XFCE4. – Grumbel Mar 7 '12 at 22:45
  • @BlueXrider you see the same problem as I do? If so, what version are you using? – Hooked Mar 8 '12 at 15:29
  • I confirmed the test code is working correctly. I get the time outs as directed. – Ringtail Mar 8 '12 at 16:12
  • 6
    Alternatively you can use notify-send "Text Here" ; sleep 3 ; killall notify-osd (where sleep 3 is example of expiration (actually killing) after 3 seconds)! – Pandya Jan 13 '15 at 9:00
45

This is a known bug: https://bugs.launchpad.net/ubuntu/+source/notify-osd/+bug/390508

(It is considered a 'design decision' by the maintainer.)

| improve this answer | |
  • 3
    This is not really a bug. It's a design decision. – Eren Tantekin Jun 25 '12 at 21:12
  • 72
    A wrong design decision can be a bug. – Boris Bukh Jun 29 '12 at 21:42
  • 24
    When software claims to do one thing while it does another thing, it is a bug. If the developers don't want us to consider it as bug, then don't claim that it acts like it doesn't. – hytromo Sep 24 '12 at 15:50
  • 10
    That's not a feature. That's a bug! When you provide a a lever to turn on the windscreen wipers and it doesn't work, then it's broken. – Matt H Mar 16 '16 at 20:48
  • 3
    @ChristopherDone With respect, it's a bug. The help for notify-send (part of notify-osd) says: notify-send --help|grep timeout -t, --expire-time=TIME Specifies the timeout in milliseconds at which to expire the notification. That's the primary interface to a user of the tool. That primary interface lies to the user and is therefore this is a bug. It's either bug with the help text or the implementation, depending on your perspective, but it's definitely a bug. – Michael Sparks Nov 30 '17 at 14:48
22

As mentioned in one of the posts above, there is a design decision to disallow this feature. Fortunately for you, other people disagree as well and have set up a PPA and you can reverse this decision for your system as well.

To solve your problem just:

sudo add-apt-repository ppa:leolik/leolik 
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get install libnotify-bin
pkill notify-osd

Optional

To add even more features to send-notify than you currently have:

From Ubuntu 16.04 onwards:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt update
sudo apt install notifyosdconfig

For versions 9.10-14.10:

sudo add-apt-repository ppa:amandeepgrewal/notifyosdconfig
sudo apt-get update
sudo apt-get install notifyosdconfig

For more information on the solution above, read this article:

Configurable Notification Bubbles for Ubuntu

| improve this answer | |
  • Unfortunately, the repository doesnt provide the package anymore, saying E: Failed to fetch http://ppa.launchpad.net/amandeepgrewal/notifyosdconfig/ubun‌​tu/dists/xenial/main‌​/binary-amd64/Packag‌​es 404 Not Found (related: askubuntu.com/questions/50/… ) – phil294 Feb 12 '17 at 19:41
  • @Blauhirn: I'm not the developer of said package. Please contact the developer – Fabby Feb 13 '17 at 9:16
  • @Blauhirn: updated answer for 16.04 onwards – Fabby Jul 10 '17 at 19:31
  • This worked! As clarification for anyone else though, you have to install the updated version of notify-osd as well. ie: sudo add-apt-repository ppa:leolik/leolik ; sudo add-apt-repository ppa:amandeepgrewal/notifyosdconfig ; sudo apt-get update ; sudo apt install notify-osd # Updates to actually useful version ; sudo apt install notifyosdconfig Many thanks! – Michael Sparks Nov 30 '17 at 14:51
  • 1
    @MichaelSparks changed upgrade to dist-upgrade. That should take care of things as notify-osd is already installed and should be upgraded for sure. – Fabby Dec 2 '17 at 21:24
4

This was an intentionally implemented contravention of established conventions without disqualification in the host terminal environment. ie. notify-send should no longer exist since it compromises the well-established expected and documented functionality, so instead, a new command notify-graffiti should now exist - What???? Wait a second ... all those scripts that use the "conventional" command name spelling will be compromised!?! by changing the convention of how the command name is spelled?!?! - hmmm This philosophy is exceptionally, paradoxically hypocritical as espoused by the Unity desktop terminal interface.

It can't be done both ways - preserving some conventions ie. the name of a command and yet not others, the functionality of a command as documented. If the functionality is to be compromised then so too should the command name so as to maintain integrity, conventionality, consistency, etc. of the user "experience", or is that user "frustration", "annoyance", "irritation", ...

ref:

Bookmark:
Notify-send ignores timeout?

| improve this answer | |
  • The "Non-expiring_notifications" and "Notification | Ubuntu App Developer" links are broken (or rather the web page they refer to is). – Keith Thompson Dec 17 '15 at 1:17
2

There is a small handy script notify-send.sh as a drop-in replacement for notify-send that enables you to close or replace previously sent notifications.

Edit: as @Glutanimate pointed out, this script supports expiration-time by default.

I couldn't get expiration-time to work in the end, so I went rather a hacky way to send a notification with 2 seconds timeout like this:

notify-send.sh --print-id test | xargs -I {} bash -c "sleep 2 && notify-send.sh --close={}" &

| improve this answer | |
  • This script is great! Thanks for sharing it here. Looks like it's now completely compatible with notify-send's original CLI arguments. I.e.: You can send a notification with a 2 sec timeout via notify-send.sh -t 2 "Hello World!". I've symlinked the script to my local $PATH directory and renamed it to notify-send. No more dealing with that subpar notify-osd implementation! – Glutanimate Apr 9 '18 at 18:30
  • Oh cool @Glutanimate ! Thanks for letting us know about it. – NiMa Thr Apr 10 '18 at 18:35
1

For those using the Cinnamon desktop environment, there's a setting that can be enabled:

Notifications > Remove notifications after their timeout is reached

| improve this answer | |
0

This is in milliseconds. I tested on XUbuntu 16.04 (Ubuntu XFCE)

notify-send -t 3000 "test"

exactly 3 seconds

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.