1

Upgrading my Ubuntu 14.04 LTS to 16.04 then 18.04 LTS left LTSP unable to boot clients. I am using the traditional 2 NIC structure on 1404, with thin clients on a physically separate subnet, and their system in chroot. It uses isc-dhcp-server and tftpd-hpa.

Trying to debug my upgraded system (including switching to dnsmasq) I came across bugs which only seem to be fixed in versions of packages later than those in the bionic repos, with no backports, so I gave up on the upgrade route.

So is there a currently reliable way of installing LTSP on 1804?

1

You should follow official guide on LTSP wiki - http://wiki.ltsp.org/wiki/Installation/Ubuntu and do not forget to add Greek PPA (ppa:ts.sch.gr).

I did not tried 2 NIC configuration yet, but 1 NIC with ProxyDHCP work as expected with Greek PPA.

1

Thanks N0rbertI already tried it and it worked first time. Seems most LTSP activity is in the educational sector these days. We're not in education so I hadn't really looked at these before. We don't have any Greek connections either, so I looked at Debian Edu first - which might work but I didn't try it because it seems to be intended for large networks with multiple LTSP servers, and needs a special router. The Greek Schools PPA seems a simpler solution. I installed the 2 NIC + chroot setup, although they seem to allow for all the alternatives too. The PPA has a much newer version of LTSP than the Ubuntu 18.04 and Debian Stable repos and they seem to have squashed all the bugs I had before.

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.