10

I'm trying to determine why horizontal scrolling isn't working for me on Ubuntu 10.10, but I'm not sure how to tell what type of touchpad is in my Lenovo thinkpad T400. I tried running lspci and lsusb but neither one showed anything along the lines of touchpad, mouse, or anything that felt like it was my touch pad. How do I tell?

14

You can use the xinput command to list all of your input devices including mice and keyboards:

xinput list

My output looks like this:

⎡ Virtual core pointer                      id=2    [master pointer  (3)]
⎜   ↳ Virtual core XTEST pointer                id=4    [slave  pointer  (2)]
⎜   ↳ ETPS/2 Elantech Touchpad                  id=11   [slave  pointer  (2)]
⎜   ↳ Macintosh mouse button emulation          id=12   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 4x6 eraser                  id=15   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 4x6 cursor                  id=16   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 4x6 pad                     id=17   [slave  pointer  (2)]
⎜   ↳ Wacom Intuos3 4x6 stylus                  id=18   [slave  pointer  (2)]
⎣ Virtual core keyboard                     id=3    [master keyboard (2)]
    ↳ Virtual core XTEST keyboard               id=5    [slave  keyboard (3)]
    ↳ Power Button                              id=6    [slave  keyboard (3)]
    ↳ Video Bus                                 id=7    [slave  keyboard (3)]
    ↳ Power Button                              id=8    [slave  keyboard (3)]
    ↳ USB 2.0 Camera                            id=9    [slave  keyboard (3)]
    ↳ AT Translated Set 2 keyboard              id=10   [slave  keyboard (3)]
    ↳ LITEON Technology USB Multimedia Keyboard id=13   [slave  keyboard (3)]
    ↳ LITEON Technology USB Multimedia Keyboard id=14   [slave  keyboard (3)]
2
  • 1
    What if my touchpad is not listed in xinput list because the kernel isn't aware of it yet?
    – nnyby
    Sep 16 '17 at 19:16
  • 2
    For this case, you must use standard pattern of checking lsusb and lspci to identify which device bus your device is on. If it's ps2 or something really odd, then you have to follow the investigation from the dmesg logs. Sep 17 '17 at 20:07
4

You may also be interested in installing the gpointing-device-settings package, which will provide more configuration options for your touchpad.

sudo apt-get install gpointing-device-settings

Once installed you can find it under System -> Preferences -> Pointing Devices.

1
  • 1
    Last updated 2013. When I tried to install via above command on Ubuntu 18.04, it says it was unavailable.
    – Ben Creasy
    Nov 1 '18 at 19:53
1

One place to look is in /var/log/Xorg.0.log, where you can search for Touchpad. I'm not sure how specific it will be, but it shows me lines such as:

(II) config/udev: Adding input device SynPS/2 Synaptics TouchPad (/dev/input/event13)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.