1

I'm having problems to execute file in my VMware folder, I tried changing permissions, but it does not change but give this error:

chmod: changing permissions of <filename> Read-only file system

I tried using chmod +x, chmod 777 and several others.

Still not able to run the file.

Please see image file permissions

Note by Yaron: During the discussion in chat we understood that the read-only file system is a CD mounted to the VM.

  • which file do you fail to execute? – Yaron Jan 14 at 8:10
  • run_upgrade.sh, I see it is set to permission -r--r--r-- – user3768971 Jan 14 at 8:11
  • in the attached photo, we can see that run_upgrade has -r-xr-xr-x permissions. i.e. it is executable – Yaron Jan 14 at 8:12
  • Do you run your commands as user root or as oxidized ? – Yaron Jan 14 at 8:14
  • sorry, it's true. It's the tar.gz file that won't extract – user3768971 Jan 14 at 8:15
0

The source of the problem is that you tried to write to a CD which is a read-only system.

You should first copy the file to a write-able folder (e.g. another folder in your VM which is located on HDD).

Afterwards if you want to extract filename.tar.gz file You can extract it using:

tar -xzvf filename.tar.gz

or by using:

tar xf filename.tar.gz

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.