23

I see an empty drop down box where the language code of the current keyboard layout should be.

To reproduce the bug: Lock screen or log out and log in again.

screenshot of keyboard layout indicator on gnome shell

I also get the same behavior on the lock screen at the time when I try to log in with my password:

screenshot of keyboard layout indicator on gdm

After I tried the workaround (below) the language code on the login screen disappeared as soon as I typed the first character of my password.

Workaround (not permanent): Switching with keyboard (Super+space) or mouse.

System info: Ubuntu 18.04.1 LTS, GNOME 3.28.2.

system info

Please indicate in the bug report if also affects you.

  • Its start happens after some this year update. No fiddling with the keyboard settings were made. – mature Jan 14 '19 at 8:22
  • Yes, it was my post. Just switch to OFF all extensions with one single switcher (in GNOME Tweaks Title), Reboot, but get same indicator behavior.. Perhaps it is worth trying to disable all GNOME Tweaks, but I'm not sure that's 100% possible now. – mature Jan 14 '19 at 8:30
  • Is ~/.config/dconf/user writable and owned by you? – Gunnar Hjalmarsson Jan 15 '19 at 1:12
  • 3
    Will be fixed in gnome-shell - 3.30.2-2ubuntu1 – Dejv Jan 30 '19 at 11:39
  • 1
    The keyboard layout indicator problem has been fixed by a recent update in Ubuntu 18.04. – karel May 20 '19 at 6:45
7

A fix was released, already verified on Cosmic and Bionic.

EnableProposed

Until is added to normal repos, to enable them on Bionic (18.04) as said here, follow these instructions to enable the proposed archive, which basically say:

  1. Enable pre-release updates: emphasized text
  2. Add to /etc/apt/preferences.d/proposed-updates

    Package: *
    Pin: release a=bionic-proposed
    Pin-Priority: 400
    

    If sudo apt-get upgrade -s return any package, something went wrong.

  3. Run sudo aptitude -t bionic-proposed
  4. Update with u
  5. Select the proposed related packages:
    • gnome-shell-common 3.28.3+git20190124-0ubuntu18.04.1
    • gnome-shell 3.28.3+git20190124-0ubuntu18.04.1
  6. Upgrade with g
  7. Restart GNOME.

Please test it and eventually suggest changes to this post. If everything went OK upvote and share your love with the developers.

| improve this answer | |
  • Could someone with the mad skills be so kind as to post an actual workaround for this annoying as hell problem that doesn't involve grabbing all proposed fixes (I just want my keyboard layout indicator back!). – GrayedFox Mar 26 '19 at 13:59
  • It seems a fix was released recently. – pomsky Apr 25 '19 at 19:28
2

After some January updates got the same problem, but on Ubuntu 18.10. Reinstalling appindicator packages (see commands below), somehow partially fixed the problem: lang indicator stop disappearing in gnome-shell, but still do in gdm.

apt install --reinstall gir1.2-appindicator3-0.1
apt install --reinstall gnome-shell-extension-appindicator

Update 2019-01-20

the commands above didn't work. worked solution, at least for ubuntu 18.10 (Cosmic), is rollback to previous version of gnome-shell and gnome-shell-common packages:

sudo apt install --reinstall gnome-shell=3.30.1-2ubuntu1 gnome-shell-common=3.30.1-2ubuntu1

and perform the reboot

optionally, but highly recommend - prevent update on those packages, like these:

sudo apt-mark hold gnome-shell gnome-shell-common

and wait for fix. after fix will be released - just unhold those packages and run update\upgrade command.

for ubuntu 18.04 (Bionic)

you should try rollback those packages to 3.28.1-0ubuntu2 version.

possible origin of the problem

the only difference between old version and version at January update is in this bugfix; he also relate to ibus, so that fix may be the cause of the "disappearing lang indicator" problem

| improve this answer | |
  • Thanks. Trying. But, isn't fix in my case. – mature Jan 16 '19 at 6:44
  • 2
    rollback gnome-shell and gnome-shell-common - from version 3.30.1-2ubuntu1.18.10.2 - to version 3.30.1-2ubuntu1 on ubuntu cosmic (18.10) completly fix the problem. I think on 18.04 rollback those packages - from 3.28.3-0ubuntu0.18.04.4 - to 3.28.1-0ubuntu2 should do the same thing. – rzrbld Jan 20 '19 at 19:41
  • 2
    according to page on launchpad ( launchpad.net/ubuntu/+source/gnome-shell ). Only difference between versions is this bugfix - bugs.launchpad.net/ubuntu/+source/ibus/+bug/1765304 think problem in that fix. – rzrbld Jan 20 '19 at 19:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.