4

I have dual booted Ubuntu along with Windows 10. I have a SSD+HDD combo where Windows is installed on SSD and Ubuntu on HDD.

I've tried reinstalling Ubuntu but the problem of large boot time still persists

The boot time calculated by the linux system on the command systemd-analyze time is as follows:

Startup finished in 6.208s (kernel) + 1min 21.627s (userspace) = 1min 27.835s graphical.target reached after 1min 18.951s in userspace

On knowing time taken by different processes systemd-analyze blame It prints:

34.239s dev-sda3.device
         26.287s plymouth-quit-wait.service
         22.271s systemd-journal-flush.service
         14.668s systemd-udevd.service
         14.500s plymouth-start.service
         13.720s snap-gnome\x2d3\x2d26\x2d1604-70.mount
         13.240s snap-gtk\x2dcommon\x2dthemes-319.mount
         12.755s snap-gnome\x2dsystem\x2dmonitor-51.mount
         10.934s snap-gnome\x2dcharacters-103.mount
         10.220s snapd.service
          9.661s snap-core-4917.mount
          7.689s NetworkManager-wait-online.service
          7.167s udisks2.service
          7.020s NetworkManager.service
          6.830s ModemManager.service
          6.778s accounts-daemon.service
          5.207s bolt.service
          5.128s networking.service
          4.559s networkd-dispatcher.service
          4.173s rsyslog.service
          3.921s systemd-tmpfiles-setup-dev.service
          3.750s thermald.service
          3.510s polkit.service
lines 1-23

Please help!

  • 3
    Possible duplicate of What are the dev-loop services that started on boot? – N0rbert Jan 13 '19 at 8:24
  • if you would like to install prelink it's decrease process startup time --attention-- After a binary has been prelinked, the address at which shared libraries will be loaded will no longer be random on a per-process basis, even if the kernel.randomize va space sysctl is set to 1. This is undesirable because it provides a stable address for an attacker to use during an exploitation attempt --source redhat-- if you want to install just type # sudo apt-get install prelink if you are not interesting in prelink because it has a security risk i suggest to try preload . – user643653 Nov 3 '19 at 21:23
0

Are you using any kind of systems that enable 3D compositors to be used as primary display servers for example Wayland or something like that?

Because plymouth-quit-wait.service seems to take a lot of time. If that's the case, please try to disable Wayland and then give a try to print systemd-analyze blame results.

You can disable it from /etc/gdm3/custom.conf by removing the # from the beginning of this line #WaylandEnable=false.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.