0

My X1E appears to suspend when I close the cover (the cover light and the power light slowly fade in and out. But when I try to resume, the screen stays dark except for an underline cursor in the upper left corner. Pressing keys does nothing.

Since Pop!_OS is based on Ubuntu and apparently has no problem with suspend/resume, does anyone know a fix?

Here are some more details:

  1. Lenovo X1 Extreme 4K display, i7-8750H, GeForce GTX 1050 Tk mobile
  2. BIOS set to Discrete graphics and no Secure Boot
  3. BIOS version 1.17
  4. Ubuntu 18.10 4.18.0-13
  5. nouveau drivers blacklisted, using nvidia-driver-415
  6. using Suspend from MATE menu, or closing lid appears to suspend: cover light and power light slowly fade in/out
  7. resume doesn't work, screen stays dark
  8. no ping or ssh response from a remote machine
  9. with grub debugging, the messages shown during resume attempt are:

Jan 11 19:03:40 pyxis kernel: [ 58.588082] snd_hda_codec_hdmi hdaudioC1D0: HDMI: invalid ELD data byte 3

Thanks !

New contributor
user1741637 is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

user1741637 is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.