I followed a tutorial that recommended installing Ubuntu 16 LTS at first and then upgrading to 18.04 to deal with the long boot time problem due to random number generation. During installation, wireless worked fine. After upgrading to Ubuntu 18.04 at some point the wifi started giving errors, perhaps immediately, I'm not sure. The errors involved microcode errors. I did updates and those went away but the wireless still gives errors. Here is the results of running a wireless script of info.

Thanks for your help.


Try to install the HWE kernel which may include newer stable drivers for your hardware and reboot.

Open a terminal window, then run the following command.

sudo apt install --install-suggests linux-image-generic-hwe-18.04

Hit ENTER if asked about installing new packages, wait until the installation is done, then reboot.

sudo reboot

I hope it helps :)

| improve this answer | |
  • 1
    This worked thanks, except just rebooting didn't work, i had to shutdown completely and then turn the machine on to get it to recognize the wireless for some reason. – user1489829 Jan 13 '19 at 1:45
  • Strange indeed. Nevertheless, I'm happy that it helped :) – linux64kb Jan 19 '19 at 15:47

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.