I seem to be able to hibernate OK using s2disk, but when I switch the laptop back on, it seems to hang half-way through the "resuming" menu. The splash screen looks healthy, it seems to be trying to resume from the correct disk, but it hangs about half-way through, with three little pips.

One great help would be - where can I find the logs, and how do I get more verbose ones?

There is some info in /var/log/pm-suspend.log, but that all seems fine, just lots of hibernate: success messages...

How do I switch on more verbose logging in s2disk? And what about the resume process, where are the logs for that, and how can I make them more detailed?

Background: the standard Ubuntu hibernate wouldn't work, so I've install uswusp and its associated tools - s2disk etc. That initially made things worse, but a fair amount of fiddling with its config, my swap size and so on seem to have got it at least seemingly successfully suspending...

[update] some config info:

RAM: 8GB swap space: 8.63GiB (NB i did try increasing swap to 16GB, didn't help)

$ sudo blkid
/dev/sda: TYPE="isw_raid_member" 
/dev/zram0: UUID="45e58d74-be57-4ad4-95de-217e9ba7d087" TYPE="swap" 
/dev/sdb: TYPE="isw_raid_member" 
/dev/mapper/isw_dgibfidibf_Volume0p1: LABEL="Ubuntu" UUID="7ca86fcb-a969-45d5-b67f-fe29bc568f4d" TYPE="ext4" 
/dev/mapper/isw_dgibfidibf_Volume0p2: LABEL="System Reserved" UUID="2A1A38861A3850D5" TYPE="ntfs" 
/dev/mapper/isw_dgibfidibf_Volume0p3: LABEL="Windows" UUID="FE6C39286C38DD59" TYPE="ntfs" 
/dev/mapper/isw_dgibfidibf_Volume0p5: UUID="dfb8af38-acf1-42be-be18-131d326a21ff" TYPE="swap" 
/dev/mapper/isw_dgibfidibf_Volume0p6: LABEL="SHARED" UUID="10BA-FE58" TYPE="vfat" 

$ cat /etc/initramfs-tools/conf.d/resume

[update 2] - have followed instructions at https://wiki.ubuntu.com/DebuggingKernelSuspendHibernateResume and submitted a bug report: https://bugs.launchpad.net/ubuntu/+source/hibernate/+bug/987109

  • Please edit your question to contain the following: Size of RAM, size of swap partition, output of sudo blkid, and content of /etc/initramfs-tools/conf.d/resume. – htorque Apr 22 '12 at 7:28

try removing cryptsetup from your system, worked for me.

  • nope... thx for trying tho! – hwjp Apr 23 '12 at 5:37

This answer may not be helpful for around 7 days, but I had a similar problem with hibernate and sleep and when I upgraded to Ubuntu 12.04 Beta all issues were solved. So I'd suggest either simply waiting till April 26th and upgrade then or Installing Ubuntu 12.04 Beta.

Hope this helps.

  • Though you would need to reenable it as hibernate is disabled by default in 12.04 as far as I know. Would be interesting to know what RAM and swap you actually have. – 23 93 26 35 19 57 3 89 Apr 19 '12 at 18:02
  • Good point I hadn't even noticed, the last time I hibernated must have been before they changed that! Also I have 1GB RAM and 2GB swap :) – Ross Fleming Apr 19 '12 at 19:25
  • nope, just upgraded to 12.04 beta yesterday, and if anything hibernate is even worse - it doesn't even get as far as shutting down now, just sticks at freezing processes – hwjp Apr 20 '12 at 8:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.