0

I don't know how it happened, but when I restarted my laptop I got an error saying: Xsession: unable to launch "gnome-session --session=ubuntu" X session --- "gnome-session --session=ubuntu" not found; falling back to default session

I then found this post:

https://superuser.com/questions/813170/unable-to-launch-gnome-session-session-ubuntu-x-session

I went to terminal more with ctrl+alt+f1 and reinstall ubuntu-gnome-desktop. It complained that it could not download ubuntu-release-manager update-manager, and update-notifier, but wasn't going to install them. When I tried sudo apt-get install update-notifier it told me to download update-notifier-common; when I tried doing that is told me I was missing gcr, debconf, default-dbus-session-dbus, dbus-session-dbus, and more. But, when I tried installing these it said they were already up to date.

Then my laptop ran out of power. When I turned it back on I realized it could not connect to the internet.

I just got my laptop two months ago, every thing I care about is backed up on github/google, I just really need to be able to use if for school. Its on ubuntu 16.04 lts.

New contributor
Felix Moses is a new contributor to this site. Take care in asking for clarification, commenting, and answering. Check out our Code of Conduct.

Your Answer

Felix Moses is a new contributor. Be nice, and check out our Code of Conduct.

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Browse other questions tagged or ask your own question.